ERROR: Operation must use an updateable query.

asp code:
Code: error:
Code: Error Type: Microsoft OLE DB Provider for ODBC Drivers (0x80004005) [Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable query. /site/content/register_act.asp, line 13 It's says it has something to do with permissions...

I set writing & reading permissions for the db and the directory that contains it through
contorl panel->Administrative Tools->Internet Information Services

I have no "security tab" when I rightclick->properties the db file or it's directory even though the file system is NTFS

in spite all these when I rightclick->properties the directory that contains the db I see a "read only" square marked in the general tab-attributes, when I try to unmark it seems to be unmarked but when I rightclick->properties again it's marked again...

what should I do

Posted On: Monday 22nd of October 2012 05:20:55 AM Total Views:  594
View Complete with Replies

Related Messages:

Data type mismatch error   (215 Views)
Hi I am getting the following error when I try to present some information from a database: Microsoft JET Database Engine error '80040e07' Data type mismatch in criteria expression. /tribute2.asp, line 168 The code relating to this is: The error line it is talking about is: Code: rsGuestbook.Open SQLstr, adocon Code: Can anyone see where I have gone wrong ... could it be something to do with the fact that 'remid' relates to another table in the database. Though when I did a reponse write on the sqlstr it is presenting the remid. Hope this doesn't sound to confusing.
Compile error: Can't find project or library   (191 Views)
There I try to use the function chr() and left() in Access2000. but it got "Complile error: Can't find project or library". Appreciate someone can help me.
The dreaded "You can't assign a value to this object" error message   (206 Views)
Hi Gang, I'm new to this forum so please bare with me. I have spent the last two days trying to resolve, or work out why on earth I am getting this error message. I am at the point of pulling my hair out - its SO frustrating so *any* suggestion would be great. I have created a small database for plant (as in flowers) details. To cut a long story short, its a simple db fronted by a form that allows me to display and add records together with an associated image (stored outside the db). I was trying to write some code that would look at the control that displays the image and, if there is no image associated with a particular record, it would display an "add new image" button. If there is an associated image, the buttons visable property is set to false. I had ammended a section of code for the forms "on current" event and saved the changes. I then changed to form view, tried to enter a new record and access throws up the error message. It does not matter which field I try to add data in, the same error still happens. I have checked, and re-checked all my code and property settings for every control and field on the form and I can not track down what is causing this error. I noticed from searching this forum that someone else had this error but the resolution does not appear to have been posted so can anyone help in any way at all. My grateful
Syntax-error in INSERT INTO-expression   (173 Views)
. I've managed to create an access-database and (fill it with some data), retrieve data from it with asp, but when I try to insert or update data with asp, I get the same error: "Syntax-error in Insert expression" or "Syntax-error in update expression" Do I have to "chmod" the database to write to it, or what (I usually work with sql-databases, and the code/syntax I believe is not wrong,as it works on another database) Conn.Execute("INSERT INTO tour(date,venue,city,link) VALUES('" & datum & "','" & venue & "','" & city & "','" & link & "')") Thank you in advanced for answering my query. //Joakim
Mismatch type error   (182 Views)
Hi I'm doing some work on an open source intranet for a friend and I've come unstuck with data types I guess. Microsoft VBScript runtime error '800a000d' Type mismatch: 'str' D:\SITES\EXTRANET\CLIENTS\../includes/connection_open.asp, line 104 I added a date field and now get this error. The process is as follows: add user - client-add.asp client-add-processor.asp (& siteSQL.asp include) the error occours on submiting the original form page new feilds: Code: ..............edited............... : : To client-add-processor.asp Code: sql = sql_UpdateClient( _ session("Name"), _ session("Rep"), _ session("Client_Since"), _ session("Standard_Rate"), _ session("Address1"), _ session("Address2"), _ session("City_State_Zip"), _ session("LiveSite_URL"), _ session("DevSite_URL"), _ session("Contact_Name"), _ session("Contact_Phone"), _ session("Contact_Email"), _ session("Contact2_Name"), _ session("Contact2_Phone"), _ session("Contact2_Email"), _ Active, _ session("client_id"), _ session("ClientFolder"), _ session("HostingPeriod"), _ session("DomainPeriod"), _ session("Notes"), _ session("WebFolder")) 'response.write(sql) Call DoSQL(sql) %> includes/main_page_open.asp Code: Function MediumDate(str) Dim aDay Dim aMonth Dim aYear aDay = Day(str) -line 104 'aMonth = Monthname(Month(str),TRUE) aMonth = Month(str) Select Case aMonth Case 1 aMonth = "Jan" Case 2 aMonth = "Feb" Case 3 aMonth = "Mar" Case 4 aMonth = "Apr" SQL Code: Function sql_InsertClient(Client_Name,Rep_ID,Active,Client_Since,Standard_Rate,Address1,Address2, _ City_State_Zip,LiveSite_URL,Devsite_URL,Contact_Name,Contact_Phone,Contact_Email,Contact2_Name, _ Contact2_Phone,Contact2_Email,HostingPeriod,DomainPeriod,Notes) dim sql sql = "INSERT into tbl_clients (client_name,rep_id,active,client_since,standard_rate,address1," & _ "address2,city_state_zip,livesite_url,devsite_url,contact_name,contact_phone,contact_email,contact2_name," & _ "contact2_phone,contact2_email,hostingperiod,domainperiod,notes) VALUES (" & _ "'" & Client_Name & "'," & _ Rep_id & "," & _ Active & "," & _ "" & DB_DATEDELIMITER & MediumDate(Client_Since) & DB_DATEDELIMITER & "," & _ Standard_Rate & "," & _ "'" & Address1 & "'," & _ "'" & Address2 & "'," & _ "'" & City_State_Zip & "'," & _ "'" & LiveSite_URL & "'," & _ "'" & DevSite_URL & "'," & _ "'" & Contact_Name & "'," & _ "'" & Contact_Phone & "'," & _ "'" & Contact_Email & "'," & _ "'" & Contact2_Name & "'," & _ "'" & Contact2_Phone & "'," & _ "'" & Contact2_Email & "'," & _ "" & DB_DATEDELIMITER & MediumDate(HostingPeriod) & DB_DATEDELIMITER & "," & _ "" & DB_DATEDELIMITER & MediumDate(DomainPeriod) & DB_DATEDELIMITER & "," & _ "'" & Notes & "')" sql_InsertClient = sql end Function
Get an error... any thoughts on what it means?   (294 Views)
I am using Access 2010 I have a form based on a table. In this form I can add records, etc. Nothing specatular. When I get to the last record and hit the next record button at the bottom, it brings me to the blank record (as if I wanted to add a new one) When I try to go back to a previous record, it get the following error: MS Access database engine cannot find a record in the table 'Locations' with key matching field(s) 'LOCATION' I dont know what this means. I have gone the literal route and actually added a field in the Locations table called Location, but that doesnt get rid of it. I am not sure what happened or when it happened because I know it didnt happen when I first created the database. If anyone can think of something that may cause this (maybe something similar happened to someone else) and possibly point me in the right direction, I would really appreciate it. I am fairly new at this so I may not be thinking along the same lines as some of the experts out there.
Customer error message.   (173 Views)
I have a table with a field's property set to Required=Yes. I have then made a form with the table field carried over. I've made a command button which saves the data. However, if I don't choose a selection for the field in question it says, "You Cant Go To The Specified Record". Now, I need to change that to a custom message of my own. I've gone into VBA, chose the command, Click. Tried adding MsgBox ("Please select the age"). Gone into form view and purposefully not chose the age field. It comes with that error above, "You cant go to...." . I choose the age from the drop down and it then comes up with the custom message afterwards! I am really confused about what to do. Can any one help me Perhaps give a certain code If you need more info please ask. I have googled it and tried a method but to no avail. Using 2007 version.
Frustrating Data Connection refresh error   (179 Views)
First of all, let me point out that this error may be caused by either Excel or Access, as they are the two programs involved. I think the cause is Access, but I may be wrong. Some background. I have an Access 2010 database and in it I have two different queries (QueryA and QueryB). Each query is pulling data from a number of local tables as well as linked tables (linked to csv documents). I also have an Excel 2010 document that has two data connections, one to each Query (DataConA & DataConB). Up until recently i was able to successfully refresh the connections. Lately, however, I've been getting a very frustrating error when I attempt this. "The text file specification '*' does not exist. You cannot import, export or link using the specification." The '*' in this case is alternating between two linked tables (csv documents that are both updated every morning). What is annoying is first it will say that the file specification is a linked table in Query A. I've refreshed the link within Access, rebuilt and overwritten the old link with a new one, but the only thing that seems to work is to shut down excel and compact and repair the database. Now I can refresh DataConA within the excel document, but when I try to refresh DataConB, I get the same error... only this time it's the file specification in the linked table for Query B. This is amazingly frustrating because I can't get both dataconnections to refresh, only one works at a time while the other kicks out the above error. I hope that made sense, this is driving me so crazy.
General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0   (230 Views)
Up until the end of last week the webserver was working fine. However since all the recommended patches were put on the Windows 2000 Server running IIS 5 the following error is now displayed: Microsoft OLE DB Provider for ODBC Drivers error '80004005' [Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x380 Thread 0x460 DBC 0x2013f84 Jet'. /library/inc_dbconnection.asp, line 10 The only thing that changed was the recommended updates were put on. Any ideas
Combo gives error "...database engine doesn' recognize '...' as a valid field name...   (169 Views)
Hi I used to have 2 forms on my database that did basically the same thing but from different points of view. One of them would let me see visits in the database by selecting a student. The other one would let me see visits in the database by selecting an advisor. So we needed to put these 2 forms into one, so when the user selected a student it would show the visits for this student or when the user selected an advisor it would show the visits for this advisor. So what I did was I put combo boxes in the "see visits by advisor" form with the intention of having users select a student there as well as an advisor. Problem is when I select an advisor it work fine and shows what it needs to show. However when I select a student it gives me this error: "The microsoft office access database engine does not recognize 'ID' as a valid field name or expression" this is the code that i have on the onclick event of the combo: Dim rs As Object Set rs = Me.Recordset.Clone rs.FindFirst "[ID] LIKE '" & Me![Combo16] & "'" If Not rs.BOF Then Me.Bookmark = rs.Bookmark this is the same code that i have on the combo to select an advisor, the only difference is instead of having [ID] i have [Advisor_ID] and it works. I don't know why the one to show a student won't work. Can anyone give me some thoughts on this
Runtime Error '3075' : Syntax error (missing operator)   (187 Views)
Good Morning, I have two sets of dates and I want the report to print the records between both sets of dates. However when I try to print I get the runtime error. The dates are date fields and selected from a combo box as well as the person who will be inputting the data (from another combo box) into a different system. My code is below. I think I am close, but am obviously missing something. Any help will be appreciated. Be gentle, this is my first post Thank you in advance! Private Sub cboDates_Click() Dim stDocName As String Dim FromDate As Date 'Name of criteria start timesheets date field. Dim ToDate As Date 'Name of criteria end timesheets date field. Dim FromOTDate As Date 'Name of criteria start OT date field. Dim ToOTDate As Date 'Name of criteria end timesheets date field. Const conDateFormat = "\#mm\/dd\/yyyy\#" Dim strWhere As String 'DataEntry Combo If Not IsNull(Me.cboDataEntry) Then strWhere = strWhere & "([DataEntry] = """ & Me.cboDataEntry.Column(0) & """) AND " End If 'Date Combo FromDate = Me.cboDates.Column(0) ToDate = Me.cboDates.Column(1) FromOTDate = Me.cboDates.Column(2) ToOTDate = Me.cboDates.Column(3) If Not IsNull(Me.cboDates) Then strWhere = strWhere & "([Date] Is Between " & Format(FromDate, conDateFormat) _ & " And " & Format(ToDate, conDateFormat) & ") AND " strWhere = strWhere & "([Date] Is Between " & Format(FromOTDate, conDateFormat) _ & " And " & Format(ToOTDate, conDateFormat) & ")" End If stDocName = "RptTimeSheet" DoCmd.OpenReport stDocName, acViewPreview, , strWhere End Sub
Question about error messages Access 2003   (209 Views)
- I am trying to work with a table in MS Access 2003. My table has approximately 60 fields. I have 2 questions about things that are giving me problems. First, when I try to enter text into several of the fields, I am getting an error message that says "Record too large." I can change some of the fields from Text to Memo, but only a few. It will not let me change as many as I need to. I tried exporting the data to Excel, making my edits and then re-importing back to Access. When I did that, it only imported only about half of the fields I needed for one record and the rest errored out. Second, I am trying to design a report using the table mentioned above. I tried to use 45 of the 60 fields for my report. When I do this, I get an error message that says "The wizard is unable to create your form or report because you chose too many fields; please try again with fewer fields." My table is big, but not as big as others I've seen in Access. I can't imagine I have hit any limitations. Can anyone help TIA!
Run-time error "2001"   (172 Views)
"You cancelled the previous operation." Im in the middle of creating a type of "log on" form for the database, using VBA to carry the logged name through to input/output stages. The code is as follows. Code: Private Sub Command6_Click() If IsNull(Me.Namebox) Or Me.Namebox = "" Then MsgBox "Please choose a VALID name from the list.", vbOKOnly, "Attention!" Me.Namebox.SetFocus End If If IsNull(Me.PassBox) Or Me.PassBox = "" Then MsgBox "You must enter a PassBoxword.", vbOKOnly, "Required!" Me.PassBox.SetFocus Exit Sub End If If IsNull(Me.PassBox) Or Me.PassBox = "" Then MsgBox "You must enter a PassBoxword.", vbOKOnly, "Required!" Me.PassBox.SetFocus Exit Sub End If If Me.PassBox = DLookup("PassBoxword", Tbl_Password, "[ID]=" & Me.Namebox) Then ID = Me.Namebox DoCmd.OpenForm "Switchboardnew" Else MsgBox "PassBoxword Invalid. Please Try Again", vbOKOnly, "Invalid Entry!" Me.PassBox.SetFocus End If intLogonAttempts = intLogonAttempts + 1 If intLogonAttempts > 2 Then MsgBox "You have entered an incorrect PassBoxword 3 times. Please contact your Database Administrator.", vbCritical, "Restricted Access!" Application.Quit End If End Sub When I hit my tied button, I get this for debugging. The NameBox = Login Name. The PassBox = Password. The table Tbl_Password, stores names the passwords for those names, thats looked up by NameBox. Any ideas Cheers! ^^
Update table error   (205 Views)
I'm trying to update a table based on information from another table. I do this to update the status: "Update Inventory set Status = 'Shipped', [Date Sold] = Date() where EXISTS ( SELECT TempInvoice.Serial FROM TempInvoice WHERE TempInvoice.Serial = Inventory.Serial) Then I use a query which gets the price and serial from the TempInvoice table, (this seemed to be working last week, but I changed something/backup got "lost") UPDATE Inventory SET [Price Sold] = (SELECT TempInvoicePriceQuery.Price FROM TempInvoicePriceQuery WHERE Inventory.Serial = TempInvoicePriceQuery.Serial) WHERE EXISTS (SELECT TempInvoicePriceQuery.Serial FROM TempInvoicePriceQuery WHERE TempInvoicePriceQuery.Serial = Inventory.Serial)" Does anyone see anything wrong with this it tells me that the operation must be done on an updateable query...
Application.CurrentProject.Connection error in loading DLL   (206 Views)
I think a problem .mdb file was created by Access 2000. It is shared and works correctly on its host and six other nodes now all running Access 2003. One one node a macro gets to Set con = Application.CurrentProject.Connection and pops up a MsgBox with Microsoft Visual Basic on the title bar and the main text Compile error: Error in loading DLL, with the .Connection property in the source code highlighted by the debugger. I re-installed Microsoft Office on that computer using the same CD and volume license as the seven other nodes that work correctly. How can I learn what DLL Is it missing Corrupt Not registered
Microsoft JET Database Engine error '80004005' Unspecified error   (169 Views)
Im new to asp and access and have been having this problem for serveral weeks. Every couple of days, all the asp pages on my site that communicate with the database start having 500 internal errors. i turned off the "Show friendly error messages" and one page gave me this specific error: Microsoft JET Database Engine error '80004005' Unspecified error /admin/submitlogin.asp, line 8 I have tried a million things and have no idea why this is happening. Im not sure what other information i should post in order to see the problem.
Snapshot error   (162 Views)
I'm with a problem with an Access Project that I can't fix no matter what I do.I already tried to find the solution in every place on Internet and I can't fix this. This is the error I have an 2003-access project with several pages of reports. Those pages of reports has several charts and data.. I need to export these data to PDF, and the solution was to export first snapshot and then on top of the snapshot file export to PDF. So far so good, could already do all that. But the problem is, when the access generates this snapshot file, at about 40% of the time it generates information that does not exist in graphics. The graphics bring data from tables based on querys, and I already performed these querys thousands of times and the data are correct. The most strange is that after having created the snapshot, I can only ask to regenerate that the error will not appear. Briefly, the error happens when I road the process that generates the snapshots via VBA, with each case in an hour (or more) page and not always happen. I am almost giving up the concert this problem !!! already updated version of the office for the service pack 3, created a new database, exported the pages separately, among other things. someone went through this problem if someone can I help you,
Syntax error Insert Into   (147 Views)
Can anyone tell me what is wrong with this statement. I get the error "Syntax error in INSERT INTO statement". I am the worst kind of user as I did not write this database and am trying to learn on the fly. Any help is greatly appreciated. This macro is supposed to insert an amount into an "Activity" record based on the Co_Default_Rate field setup in the CompanyInfo table. INSERT INTO [FORMS]![Activity]![Amount] SELECT (CompanyInfo.Co_Default_Rate) FROM CompanyInfo WHERE CompanyInfo.Co_Number = [FORMS]![Installs]![Installs_Co_Number];
Data field entry error   (161 Views)
I've join a small company who uses access to store a route card system. Unforunatly it's partially broken and nobody seems to know how to fix it. Instead of bodging it forever i'm hoping to fix it. My access knowledge is fairly limited so please keep it simple The route cards are fairly standard, the primary key beening the route card number, the are various fields material, order date, etc. The problem is when you enter the data into 3 of these fields access repeats the data to all the forms. At the moment we're having to leave them blank and fill them in by hand, which means we don't have the data on computer. Anyone know any possible causes for this
#Name error in form text box--passing from subform   (341 Views)
Hi--I am working on a database which is a modification of the following MS Access 2003 Order Management template: (URL address blocked: See forum rules)=CT101426031033 In my database, I have a subform called sbfOrderDetails, which in its Form Footer has a text box that sums the items in the order and is called OrderDetailsTotal. I am trying to pass that value to a text box in the main form called OrderSubtotal. I have three questions: 1) What is the proper syntax to use to get the value of the subform control into the OrderSubtotal control on the main form I have tried various permutations and continue to get a #Name error. 2) If you look at the expression in the Order Subtotal control of the Add and Manage Orders form in the original Order Management template, it looks like this: =[Order Details Subform].Form!OrderDetailsTotal When I try to replicate that in my database, I cannot--if I add brackets around my subform name and press Enter, Access adds brackets around everything in the expression, i.e. =[sbfOrderDetails].[Form]![OrderDetailsTotal] (which returns a #Name error). If I edit out the brackets I don't want and then press Enter, it puts the brackets back in. In other words, Access keeps trying to "fix" my expression by either having brackets around each item, or no brackets at all! This is really annoying; is there any way to turn it off 3) When sbfOrderDetails is set to Single Form view, I can see the Form Footer (and the value in the OrderDetailsTotal text box as well). When it is set to Datasheet view, I cannot. Why Thank you very much, lcnlit PS>I cannot attach my database since I am a new poster, and the forum is disabling the URL of the Microsoft template as well.