SEARCH YOUR SOLUTION HERE  

using utl_http pl/sql package

HI,

When I fire below query at our development database SqlPlus prompt it works fine but same query when fired on production gives me error

select utl_http.request('http://www.yahoo.com') from dual;

The error given on production DB is

ERROR at line 1:
ORA-06510: PL/SQL: unhandled user-defined exception
ORA-06512: at "SYS.UTL_HTTP", line 174
ORA-06512: at line 1

What is stopping me on production database to use utl_http.request

please reply

sandeep

Posted On: Wednesday 7th of November 2012 06:26:19 AM Total Views:  248
View Complete with Replies




Related Messages:

Addnew does not work when trying to create a record in mysql using MYOLEDB.   (171 Views)
I access a mysql database from asp. I used ODBC in the begining but I had problems with openschema(adSchemaColumns) procedure and then I decided to use MYOLEDB. I had a program from which I created a record in a mysql database table. This program worked while using ODBC for the connection to the mysql database, now that I use MYOLEDB, I get no error but the record is not created. Any idea Thank you very much.
update using AS400 stored procedure and C#   (201 Views)
I am currently calling a stored procedure to retrieve a single record on a DB2 AS400 table. The code is the following OdbcConnectionCCConnection=newOdbcConnection(strConn); OdbcDataAdapterCCCommand=newOdbcDataAdapter("CALL"+CCLibrary+".GETCCAUTHINFO()",CCConnection); //MarktheCommandasaSPROC CCCommand.SelectCommand.CommandType=CommandType.Text; //AddParameterstoSPROC OdbcParameterparameterPCFlag=newOdbcParameter("CCPCFLAG",OdbcType.Char,1); parameterPCFlag.Value="N"; CCCommand.SelectCommand.Parameters.Add(parameterPCFlag); //CreateandFilltheDataSet DataSetds=newDataSet(); CCCommand.Fill(ds); returnds; I would like to change the PCFlag.Value to "Y" and update the field back on the AS400. Can anyone help me out here I have never created an UPDATE stored procedure (should be straight forward though) My biggest concern is the part what code I use to call the stored procedure such as the CCCommand.Fill(ds) part. It seems the Fill method will fill a dataset. I guess what I am looking for is a method to run the stored procedure with the appropriate parameters to allow the update to take place. Any help would be greatly appreciated and I will answer any questions you have to clarify this problem. Code snippits also greatly appreciated. Thanking you in advance Stephen Fisher
Connecting to Oracle 9i using COM component and ODBC   (177 Views)
In Windows 2000 and Visual Studio 2003, I am trying to use a COM component in an ASP.NET web page that connects to an Oracle 9i db on a Windows 2000 Server through ODBC. This is the way I have to do it. The code and ODBC works in a normal .NET windows application. The code is as follows with all the appropriate declarations made. As I said, it works in a regular windows form: using System; using System.Collections; using System.ComponentModel; using System.Data; using System.Drawing; using System.Web; using System.Web.SessionState; using System.Web.UI; using System.Web.UI.WebControls; using System.Web.UI.HtmlControls; using MiceDataServer; MiceDataServer.Interop.IActiveIncidents coll = new MiceDataServer.Interop.ActiveIncidentsClass(); coll.(); When it gets to coll.(), which brings back all active incidents, and there are active incidents, I get two kinds of errors: I get a pop-up dialog that says aspnet_wp.exe got an "Assertion Failed" error in thrdcore.cpp at line 659 and line 375. These lines have something to do with ASSERT_VALID(this) and ASSERT_VALID(pThread) respectively; I also get a browser generated error: Exception Details: System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x80040104. This error apparently has something to do with not being connected. I have given the ASPNET user every conceivable permission and access that I can find. It is in the Administrator Group, it has full control over the Oracle directories, it has been added to the Oracle db users. I coded the web.config file to impersonate and not impersonate. I have played with the username and password in the machine.config as well. I have allowed all things (Read/Write/Executeetc.) in IIS. ODBC compnents are up to date. The MDACs are up to date. I have tried both the Microsoft ODBC for Oracle component and the Oracle ODBC component. Oracle client is installed. Two of us are working on this and we both get the same errors. My co-developer even installed an Oracle 9i db on his local PC and it does the same thing. He did the original prototype for the web page a few months ago and it worked then, but now...nothing. Once again, it works in a regular .NET Windows Application. The COM component and ODBC even works in Access 2000 generated reports. Can anyone please help me
Some advise on feasibility of using snapshot please.   (236 Views)
Hi , I need some advise on implementing fast read only snapshots on an Oracle 8.0.3 database (total about 9GB size of data). The snapshots are to be done every 30 minutes (!!!). First and foremost, I have to say that I have my doubts, because this is a rather high IO database, so the snapshot logs will be quite big even if they are cleared every 30 minutes. Also, I am afraid that implementing this snapshot scheme will cause great workload for the server. What I need help with is measurement and justification. I have no idea how to go about measuring the projected increase of server workload. Also, I don't know how to estimate the size of the snapshot logs on the master side. I know the size depends on the amount of changes that occur on the master tables, but like I said, how to measure these Is this the way that snapshots are meant to be used I thought snapshots were usually used to replicate a remote server once or twice a day, not every 30 minutes. Many
Single Node to RAC using dbca   (136 Views)
hi, I am in the process of converting the Single instance to RAC (2 node) using dbca. SI is on Node A on ext3 filesystem. RAC nodes are : Node A (SI lies on same node Local FS ) Node B Using dbca from SI oracle home, i created a Template. This template is not visible, when i try to Create db by invoking dbca from RAC oracle home Am i missing something Is my SI node also has to be on cluster, before converting to RAC I am using 10.2 on linux, with ocfs2 as shared FS. Thx.
Restoring database using Cold Backup but changing SID   (157 Views)
Hi I don't what I am doing correct but what I wanted is I have two Sun1 and Sun2 Servers on Sun2 I have database SID= CRP, on Sun1 I have Oracle Binaris . I wanted to create an instance on Sun1 using cold backup from Sun2. What I did 1. I took cold backup of CRp on Sun2 transferred to Sun1 in appropriate directory and permission 2. I created a trace file from Sun2 transferred to Sun2 3. Then I edited the control file to chnage SID from CRP to TST 5. I staretd the database with nomount option 6. Then I used the trace file to create a control file 7. I am getting the error CREATE CONTROLFILE REUSE DATABASE "TST" NORESETLOGS NOARCHIVELOG * ORA-01503: CREATE CONTROLFILE failed ORA-01161: database name CRP in file header does not match given name of TST ORA-01110: data file 1: '/d02/oradata/TST/system01.dbf' ORA-01507: database not mounted ALTER DATABASE OPEN Any Feedback
Query using LIKE   (142 Views)
I've read that using LIKE clause in the where query will inhibit index usage on the column. E.g.select * from ABC where id like 'bc12%' and country='US';If i have the above query and an index on column id, the query will not use the index. To allow index usage, the full id should be typed in the query. However, this will add to the inconvenience of end users as they will have to typed in the full id. Is there any way which i can reduce the cost of having LIKE query Greatly appreciate it if you can show me a link or 2.
Query not using Index   (169 Views)
Hi , I am using the following query ,but i am not able to understand why this query is not using index. The tables are analyzed and i have a index on data_date_id and country on table f_scb_me_txn. F_scb_me_txn is the biggest table having 167366 records while d_reporting month is a very small table having only 10 records.Can any one explain me the reason.
Overwritting existing tables using IMP   (96 Views)
Is there a command to overwrite existing tables of the same when using IMP73 of Oracle 7.3.4 Here is my exsiting cmd line parameters: IMP73 user/password file=c:\temp ignore=y commit=y
orakill failing when connected using terminal services client   (185 Views)
When i connect to my database server using a terminal services client and issue a orakill command it gives me a Could not attach to Oracle instance error. Any ideas on how do I get around this.
What Tablespace a user session is using   (250 Views)
Hi all, Is it possible to find out which tablespace(s) a user session is using
using sequence cause inserted rows not in order   (220 Views)
Halu.. i wanna ask about inserted records using sequence. I created a seq for table t1. I insert 10 rows or record and the id (which is the pk) shows the records in order (1.2.3.4.5.6.7.8.9.10). Then i delete one of the record (where id=3). I inserted one record into table t1 but when i select back the id appeared to be not in order which is id=1,2,11,4,5,6,7,8,9,10. Why is this happening Why the next record is inserted in the space of id=3 whihch i had deleted And how to resolve this
using OEM for SQL server   (165 Views)
Can you use OEM for SQL server
update from sqlserver to oracle using triggers   (175 Views)
I am wanted to update data using triggers from sql server to oracle using linked servers. I am getting the following error "[MICROSOFT] [PODBC SQL SERVER DRIVER][SQL SERVER] THE OPERATION COULD NOT BE PERFORMED BECAUSE THE OLE DB PROVIDER 'MSDAORA' DOES NOT SUPPORT DISTRIBUTED TRANSACTIONS" What is the parameter that I should set for this to work.
Unexpected results using rownum   (115 Views)
I'm trying to return just 100 rows from a table with the following code...... Code: select membership_number, min(response_date) from question_response_001 where response_date between to_date('01/04/2004','dd/mm/yyyy') and to_date('30/06/2004','dd/mm/yyyy') and rownum < 101 group by membership_number ) but I keep getting different result sets returned, i.e., 100 rows, 97 rows, 86 rows. Is the 'group by' somehow affecting this
To remove large no.of files using rm *.req gives Error   (255 Views)
Dear , I need to delete large no. of files in a purticular directory in Solarix 8, using rm *.req But, rm prompts "Long List Error", so, you can not remove" Could some one throw some light on this. TIA Anandharaj
What is causing this error. Please help   (217 Views)
I've been stuck on this problem for most of the day. Anyone know why i keep getting the error "ORA-00604: error occured at recursive SQL level 1 ORA-06553: PLS-213: package STANDARD not accessible" I'm using OraHome90. I get this error when i try and create a new table or try to delete one. Can someone please help me out Thank you.
Test Plan for Online Backup using Legato NMO   (103 Views)
Dear , I am needing to produce a test plan for doing online backup of Oracle 8i using Legato NMO. As I am a newbie in Oracle, I need some guidelines for formulating this test plan. Any things should I be watching out for Server : Tru64 V5.1 TIA, Ryansamy
standby db using different SID   (233 Views)
Can I create standby DB using different oracle SID I'm using 2 seperate servers here.
SQL*Loader using Variables   (109 Views)
I am loading some files with the first twelve positions of each record containing the key value. When generating the file to be loaded into the database, the programmer starts with 1 for the key value and increments by one. My situtation is that I need to override what the programmer plugs into the key with a beginning value for the first record being loaded, (and incrementing by 1 for each subsequent record). I have done this with SQL Server and had a variable at the beginning of the script that I would put the beginning key and it would automatically increment by one for each subsequent record loaded. However, it's been awhile and I don't have an example and imagine if it can be achieved in SQL*Loader, it is probably different. Any guidance with this is appreciated. Neil