SEARCH YOUR SOLUTION HERE  

TNS-12560: TNS:protocol adapter error

Please help,

I have 8.1.7.4.1

I run sqlplusw from server without any problems, but if I launch svrmgrl from cmd on server - error occurs:

TNS-12560: TNSrotocol adapter error

What can be wrong

all my oracle details see below:





tnsnames.ora:

STAT.EUR.NSROOT.NET =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = alacmesd002)(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = stat)
)
)

INST1_HTTP.EUR.NSROOT.NET =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = alacmesd002)(PORT = 1521))
)
(CONNECT_DATA =
(SERVER = SHARED)
(SERVICE_NAME = MODOSE)
(PRESENTATION = http://admin)
)
)


sqlnet.ora:

NAMES.DEFAULT_DOMAIN = eur.nsroot.net

SQLNET.AUTHENTICATION_SERVICES= (NTS)

NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)




sqlnet.log

***********************************************************************
Fatal NI connect error 12560, connecting to:
(DESCRIPTION=(ADDRESS=(PROTOCOL=BEQ)(PROGRAM=oracle)(ARGV0=oraclestat)(ARGS='(DESCRIPTION=(LOCAL=YES )(ADDRESS=(PROTOCOL=beq)))'))(CONNECT_DATA=(SID=stat)(CID=(PROGRAM=C:\oracle\ora81\bin\svrmgrl.exe)( HOST=ALACMESD002)(USER=Administrator))))

VERSION INFORMATION:
TNS for 32-bit Windows: Version 8.1.7.4.0 - Production
Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 8.1.7.4.0 - Production
Time: 14-JUL-2004 01:46:04
Tracing not turned on.
Tns error struct:
nr err code: 0
ns main err code: 12560
TNS-12560: TNSrotocol adapter error
ns secondary err code: 0
nt main err code: 530
TNS-00530: Protocol adapter error
nt secondary err code: 2
nt OS err code: 0

Posted On: Thursday 15th of November 2012 09:40:55 PM Total Views:  210
View Complete with Replies




Related Messages:

Error while using tableadapters with oracle database   (352 Views)
, I am connecting to oracle 10g database. I have created a dataset (DataSet1.xsd) in the app_code folder and configure it to connect to oracle data base . i have a grid view in my Products.aspx page and in the page_load event handler of Products.aspx i have written the following code ProductsTableAdapter productsAdapter = new ProductsTableAdapter(); GridView1.DataSource = productsAdapter.GetProducts(); GridView1.DataBind(); but the problem is that the website is not building . The error i am getting is Error 1 The type or namespace name 'ProductsTableAdapter' could not be found (are you missing a using directive or an assembly reference) Can u tell which Reference im missing in my .cs file. i am using the following references. using System.Web.UI; using System.Web.UI.WebControls; using System.Web.UI.WebControls.WebParts; using System.Web.UI.HtmlControls; using System.Data.OracleClient; using System.ComponentModel.Design; using System.Data.OleDb; using System.Data.ProviderBase; using System.Data.Odbc;
data adapter's function parameter question   (94 Views)
Is it possible to pass an array of paramenter into the fill() or getdata() method created by the dataadapter designer Because i want to use the "in" statement, for example, select * from table1 where table1.id in (:paramenter)
tableadapter parameters   (319 Views)
trying to create several methods of get by's for a table. When I try to add a parameter to the query I get ORA-01036 or ORA-00936. How do you define the parameters if you are using the add query... process of the wizard With the SQL it seems straight forward but not with Oracle. I am using a 9i database, don't know if that makes a difference
Reading data from Excel using data adapter   (84 Views)
Hi , I am reading data from excel sheet and then connectingit with a datagrid. But the problemthatI m facing during this is, data grid is not showing all the data of excel sheet(specially dates and numbers). But ifI am taking a small range it is showing all data. Can any one give me the solution for this. I m using data adapter and oledb connection for it.
Global temporary table with oracledataadapter   (207 Views)
I have created a global temporary table as create global temporary table temp_table_name on COMMIT DELETE ROWS AS Select * from abc; This is creating my table sucessfully. Now i have written a package containg a Stored Procedure. In that Stored Procedure i am PROCEDURE PROC_NAME((p_requirement_list_cur IN OUT requirement_list_cur)) AS INSERT INTO temp_table_name SELECT * from abc; OPEN p_requirement_list_cur FOR SELECT * FROM temp_table_name END SP_NAME; END PROC_NAME; Now i am calling this Stored Proc from ado.net oracledataadapter. i m writing the code as: try{ created connection created new command command.connection=con; command.parameters.add(-----------); command.execute (connection,sp_name,parameters) dataadapter.selectcommand=command; da.fill(ds); } catch { ...some statements... } finally { objAdapter.Dispose(); objConn.Close(); objConn.Dispose(); } while filling ds it is saying that no object found IF on another end i am creating temporary table ON COMMITPRESERVE ROWS Then it is working fine....Any suggestions plz...
ORA-12560: TNS:protocol adapter error   (365 Views)
I have experienced this error 3 times during the last 3 days. I connect to the database using the "Enterprise Manager Console" and sql plus from oracle and everything looks fine. I can connect. This leads me to believe the problem lies elsewhere - not with oracle, but with .net. In the eventlog an error is recorded (see exception below) It helps to restart the IIS server, but it doesn't take long before the error occured again. Does anybody have a clue vent code: 3005 Event message: An unhandled exception has occurred. Event time: 20.09.2006 14:19:06 Event time (UTC): 20.09.2006 12:19:06 Event ID: c2e7aa9e6aab4960a4c67d39c37fa6e7 Event sequence: 284 Event occurrence: 5 Event detail code: 0 Application information: Application domain: /LM/W3SVC/1320317252/Root-1-128032278225010000 Trust level: Full Application Virtual Path: / Application Path: D:\AirquisInfo\Test\ Machine name: DEV0 Process information: Process ID: 3140 Process name: w3wp.exe Account name: NT AUTHORITY\NETWORK SERVICE Exception information: Exception type: OracleException Exception message: ORA-12560: TNS:protocol adapter error
ReportViewer control with .Net adapter   (112 Views)
Has anyone used the .Net driver with ASP.NET 2005 ReportViewer I connect to db and run normally, but I am in need to create some reports and am looking for alternatives to using plain Grid controls. If anyone has a process to follow for using the ReportViewerI would appreciate the input Alternatively, if anyone has use Crystal Reports with the .net driver I would like to hear that as well.. THX
TNS-12640 - Authentication adapter initialization failed   (378 Views)
I have a C++ application trying to connect to an Oracle8 database using an ODBC DSN. The connection fails showing the following error : 'TNS-12640 - Authentication adapter initialization failed' . Do you know any reason why I would get a message like that
TNS-12560: TNS:protocol adapter error   (131 Views)
Hi. I have installed 10g DB server on Linux 3. The DB is running properly. However when I do a TNSPING fro a windows client I am unable to connect. I can ping the server from the client and vice versa. The following is the tnsnames.ora entry: infr2 = (description = (address_list = (address = (protocol = tcp)(host = 192.168.0.102)(port = 1521))) (connect_data = (sid = infr2))) PING RESULTS FROM SERVER TO CLIENT: [root@infr2 etc]#ping 192.168.0.100 PING 192.168.0.100 (192.168.0.100) 56(84) bytes of data. 64 bytes from 192.168.0.100: icmp_seq=0 tt1=128 time=0.279ms .. .. 6 packets transmitted, 6 recieved, 0% packet loss, time 5013ms PING RESULTS FROM CLIENT TO SERVER C:\Documents and Settings\natik>ping 192.168.0.102 Pinging 192.168.0.102 with 32 bytes of data: Reply from 192.168.0.102: bytes=32 time
TNS protocol adapter error   (112 Views)
, I am trying to create a database with Oracle 816. 9I and 817 also exist on the same box. I need to login to sqlplus to run the create database script, however i get the Oracle Tns protocol adapter error when i login. I am using a windows 2000 server box. I have the listener started and have edited the tnsnames.ora file accordingly.
update method of data adapter is not working with oraoledb.oracle provider   (196 Views)
Hi , I am getting an error of "Dynamic SQL generation for the UpdateCommand is not supported against a SelectCommand that does not return any key column information." when I use oraoledb.oracle provider. This isweird because the table contains primarykey. If I use msdaora.1 as provider then everything works fine. (I have to use oracleoledb as provider, since I want to insert images to database and biggest limitation of msdaora.1 is it could not do it). If you want to reproduce scenario, please copy and paste the following. Table defination: CREATE TABLE ASO226_TEST2.ORDERS ( NAME VARCHAR2 (10), ORDERNO NUMBER (5) NOT NULL, ODATE DATE, CONSTRAINT ONO_PK PRIMARY KEY (ORDERNO) ) TABLESPACE ASO226_TEST2 LOGGING NOCACHE STORAGE (BUFFER_POOL DEFAULT); Source code: Just take one button and in click event paste following: string constr = "YOUR CONNECTION STRING"; OleDbConnection con = new OleDbConnection(constr); con.Open(); string strCmd = "select name,orderno,odate from orders"; OleDbCommand cmd = new OleDbCommand(strCmd, con); OleDbDataAdapter adp = new OleDbDataAdapter(cmd); DataSet ds = new DataSet(); adp.Fill(ds); // DataColumn[] dtc = new DataColumn[1]; //dtc[0] = ds.Tables[0].Columns[1]; // ds.Tables[0].PrimaryKey = dtc; ds.Tables[0].Rows[1][0] = "hs11"; OleDbCommandBuilder cmb = new OleDbCommandBuilder(adp); //adp.UpdateCommand = cmb.GetUpdateCommand(); adp.Update(ds.Tables[0]); con.Close(); I tried lots of things but no luck yet. Thank you for your time. Any suggestions or hints would be welcome. -Hitesh
Can I use subquery sql to create a strongly type table adapter connecting to Oracle   (237 Views)
I have been trying to create a sql statement that uses a subquery to join 2 oracle tables to create a strongly typed table adapter. For example: Select productName, (select catetoryName from categories where categories.category_id = products.category_id) as Category from Products In the ASP .Net tutorials this is recommended so the insert, update and delete commands can be auto generated by visual studio 2005. I have done this connecting to a SQL Database (with no problems) but am not sure it is possible when connecting to an Oracle Database using the Oracle Client. When I use the above command I receive thefollowing error when Iclick Finish for the table adapter: Generated SELECT statement. Error in SELECT clause: expression near SELECT. Error in SELECT clause: expression near FROM. Missing FROM clause. Error in SELECT clause: expression near,. Unable to parse query text. Does anyone know if this is possible to do when connecting to an Oracle Database If it is possible, can you please show me the syntax of the command.
How to debug data adapter errors in visual studio   (239 Views)
Hi. I've gota C# application that uses an ODBC connection to retrieve data from a DB2 database. When running the application I get the following error: [OdbcException: ERROR [HY000] [IBM][Client Access Express ODBC Driver (32-bit)][DB2/400 SQL]SQL0802 - Data conversion or data mapping error.] Now it just so happens that this application is designed to retreive the data through a mail merge in word. It's using the Microsoft.Office.Interop.Word assembly to create a Word.Application object, then passing the necessary ODBC connection string and sql statement to the word document's MailMerge.OpenDataSource() function. When I run the application which opens open the deed word document, and activate the mail merge feature, a certain number of records will be successfuly retrieved before I get the above mentioned error. As such, I was able to tell exactly which record contained the problem that was causing the exception. It turns out that the following sql expression SELECT * FROM CXLIB.TABLE WHERE CAST(SUBSTR(LTRIM(CXLIB.TABLE.FIELD), 2, LENGTH(CXLIB.TABLE.FIELD)) AS INTEGER) > 40 which is using an integer castto compare a dollar amount is failing when encountering a dollar amount that contains a comma. I'm still looking into resolving this problem. But it occurred to me that had I not been working witha Wordmail merge, I would have been at a lossin determining the cause of the problem. In fact, I triedduplicating this query in a separate application that usesanOdbcDataAdapterto fill a dataset and the exception is thrown immediately after the DataAdapter's fill method. Lacking experience, I would have had no clue that a certain number of records had been successfully retrieved and would have thought instead that there was a problem with my connection. Can anyone educate me on how I could have successfully debugged this issue within Visual Studio or elsewhere
Oracle dataadapter.update throws concurrency execption   (113 Views)
Hi Here is the code orDa=newOracleDataAdapter(Qry,conn); InvDs=newDataSet(); orDa.Fill(InvDs,"TABLE1"); orDa.UpdateCommand=newOracleCommand("UPDATETABLESETCOL1="+ ":iCOL1whereID=:iID",conn); orDa.UpdateCommand.Parameters.Add(":iCOL1",OracleDbType.Blob,0,"PDF"); orDa.UpdateCommand.Parameters.Add(":iID",OracleDbType.Varchar2,0,"INVOICE_ID"); foreach(DataRowinvDrindt.Rows) { dtPDF.Rows[i]["COL1"]="test"; i++; } intnRows=orDa.Update(dtPDF); This works fine in development local machine connected to dev database. But when i move the same to staging server and run it. It throws exception "Concurrency violation: the UpdateCommand affected 0 of the expected 1 records." The table does have a primary key. I also tried dt.AcceptChanges() and dt.EndInit() after doing research in different forums. Really not sure why it works in dev and fails in staging server.
Creating tableadapter in Dataset with MYSQL connector 5.2.2 give error Source: Microsoft.VSDesigner, ErrorCode:-1   (183 Views)
I am using connector 5.2.2 to connect to a mysql server. Trying to add a tableadapter to a dataset gives and error Source: Microsoft.VSDesigner, ErrorCode:-1 whenever there is a FK constraint between that table and a preexisting tableadapter on the dataset. Example If I have a tableadapter to table tbladdress and that table has a FK tothe primary key fieldin table tblstate when I try to create a table adapter to tblstate I get the error. If I remove theFK the table adapter will create just fine. I really dont want to have to remove my FK constraints in my database to make use of datasets. ANy ideas
Is there a limitation of number of rows to oracle adapter ot to dataset?   (229 Views)
I wrote a simlpe program that fill datasetvia data adapter of oracle(select command). most of the times it works, but sometimes where it has to return large number of rows it returns 0 rows. What can I do ro solve it
Copy from table to DataSet from dataadapter Fill() method   (226 Views)
I have a generic method which return DataSet. protected DataSet ExecuteDataSet(string Query); Some background information, I am using third-party data provider to get data from the table and the table is encrypted. ApolloTable table = new ApolloTable(); table.TableName = "C:\\Data\\employee.dbf"; table.OpenMode = ApolloOpenMode.ReadWrite; table.Open(); Can I copy data from the table to dataset without command eg. ApolloDataAdapter da = new ApolloDataAdapter(); ApolloConnection connection = new ApolloConnection(); connection.Database = "C:\\Data"; connection.Open(); DataSet ds = new DataSet(); da.Fill(ds, table); The reason I need to copy from table to DataSet if I need the 'table' to decrypt the table first.
Is it possible to connect to an Oracle database using datasets and tableadapters as you normally do with MS Server?   (216 Views)
I pretty much always used dataset files and tableadapters to call my stored procedures on MS Server, but now I have to work on an Oracle database. Can I do the same thing or are there different ways for oracle What are best practices concerning this Any suggestions will be very much appreciated, E
TNS:protocol adapter error   (107 Views)
hi experts i am facing below problem actually i am able to login manually means(from allprograms-->oracle......----->sql plus by providing user name , password , host string) and through wizard my application is getting connect to database . but problem is when i run my application. it is giving below error . it is giving same error for sql server 2000 also. plz suggest me what to do but for windows application i am able to run my application it is not giving any error with same procedure. ORA-12560: TNS:protocol adapter error Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.Data.OracleClient.OracleException: ORA-12560: TNS:protocol adapter error Source Error: Line 39: OracleConnection con= new OracleConnection("User ID=XXXXX;Data Source=mipl;Persist Security Info=False;password=XXXXX");Line 40: OracleDataAdapter da= new OracleDataAdapter("SELECT SMS_CODE,SMS_MESSAGE FROM SMS order by sms_code asc",con);Line 41: da.Fill(ds,"sms");Line 42: Line 43: DataGrid1.DataSource =ds.Tables["sms"]; Source File: e:\shiva\datagrd\webform1.aspx.cs Line: 41 Stack Trace: [OracleException: ORA-12560: TNS:protocol adapter error] System.Data.OracleClient.DBObjectPool.GetObject(Object owningObject, Boolean& isInTransaction) System.Data.OracleClient.OracleConnectionPoolManager.GetPooledConnection(String encryptedConnectionString, OracleConnectionString options, OracleConnection owningObject, Boolean& isInTransaction) System.Data.OracleClient.OracleConnection.OpenInternal(OracleConnectionString parsedConnectionString, Object transact) System.Data.OracleClient.OracleConnection.Open() System.Data.Common.DbDataAdapter.QuietOpen(IDbConnection connection, ConnectionState& originalState) System.Data.Common.DbDataAdapter.FillFromCommand(Object data, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, String srcTable) datagrd.WebForm1.Page_Load(Object sender, EventArgs e) in e:\shiva\datagrd\webform1.aspx.cs:41 System.Web.UI.Control.OnLoad(EventArgs e) System.Web.UI.Control.LoadRecursive() System.Web.UI.Page.ProcessRequestMain() Version Information:Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573 -- EDITED BY Longhorn2005 Forum Moderator
ORA-12560: TNS:error adapter protocol   (217 Views)
I've searched all over the internet and I just can't find how to solve this. I'm using VS2005 Pro with Oracle 10g XE and from an aspxwebpage trying to access the database returns: ORA-12560: TNS:error adapter protocol but if I try to make a direct Oracle connection from VS2005 I get this: ORA-12514: TNS:listener does not recognize the requested service I'm using the ODP.NET (from oracle to develop in .NET),I can perfectly access and see the database through SQL*Plus I would appreciate some help, Oracle support is terrible.