SEARCH YOUR SOLUTION HERE  

sqlnet.log errors

Dear Sir,

Could anyone let me know the cause of these errors in sqlnet.log


------------------------------------------------------------------------


Fatal NI connect error 12640, connecting to:
(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))

VERSION INFORMATION:
TNS for 32-bit Windows: Version 8.1.7.0.0 - Production
Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 8.1.7.0.0 - Production
Time: 24-AUG-2002 10:15:32
Tracing not turned on.
Tns error struct:
nr err code: 0
ns main err code: 12640
TNS-12640: Authentication adapter initialization failed
ns secondary err code: 0
nt main err code: 0
nt secondary err code: 0
nt OS err code: 0





Posted On: Thursday 15th of November 2012 10:30:19 PM Total Views:  268
View Complete with Replies




Related Messages:

missing sqlnet.log in winnt   (178 Views)
Hi.. i wanted to view the sqlnet.log on the client side on winnt but I am not able to view them. in the sqlnet.ora parm I entered the following settings yet i dont see any sqlnet.log generated when i use my application to connect to oracle even if i sqlplus to oracle. Any ideas LOG_FILE_CLIENT=sqlnet.log LOG_DIRECTORY_CLIENT=drograms\net8home\network\log
Returning/logging errors approaches   (213 Views)
Originally posted by chrisrlong I'm thinking of using autonomous transactions (conditionally, with retries for when distributed transactions cause failure) Hi Chris, I'm a bit confused about the above part of the story. Are you saying that distributed queries (i.e. some tables are accessed via db links) are involved If so, then I guess you might have a problem: autonomous transactions can not be used with distributed queries/transactions! Or have I completely missed that part
Table creation giving errors   (197 Views)
, We have Application Owner with the name TBASAPP with default tablespace TBS_DATA_SML AND Temporary Tablespace TEMP. We have 4 tablespaces TBS_DATA_SML,TBS_DATA_MED,TBS_INDX_SML AND TBS_INDX_MED. I have a script to create tables in the schema.But for some tables it is giving errors "ORA-00907: missing right parenthesis". other tables get created. Below is the example for one table which is giving error. I came to conclusion that tables which are having REFERENCES clause are giving errors. SQL> CREATE TABLE "TB_COLOR_THEME"("THEME_CODE" NUMBER NOT NULL, 2 "COMPONENT_CODE" NUMBER NOT NULL, 3 "ACTIVE_FRONT" NUMBER NOT NULL, 4 "ACTIVE_BACK" NUMBER NOT NULL, 5 "DISABLED_FRONT" NUMBER NOT NULL, 6 "DISABLED_BACK" NUMBER NOT NULL, 7 "ERROR_FRONT" NUMBER NOT NULL, 8 "ERROR_BACK" NUMBER NOT NULL, 9 "NORMAL_FRONT" NUMBER NOT NULL, 10 "NORMAL_BACK" NUMBER NOT NULL, 11 CONSTRAINT "PK_TB_COL_THEME" PRIMARY KEY("THEME_CODE","COMPONENT_CODE"), 12 CONSTRAINT "FK_THEME_COMP" FOREIGN KEY("COMPONENT_CODE") 13 REFERENCES "TB_COMPONENT"("COMPONENT_CODE") 14 USING INDEX TABLESPACE TBS1U_INDX_SML) 15 TABLESPACE TBS1U_DATA_SML 16 / USING INDEX TABLESPACE TBS1U_INDX_SML) * ERROR at line 14: ORA-00907: missing right parenthesis Pls tell me what I have to do solve this issue. Paresh.
streams not propagating/flowing but no capture/apply errors   (130 Views)
I'm unable to resolve an issue with streams, local capture, uni-directional. I've set up streams on source and destination with no errors showing in the capture, propagation and apply views. The views show 'enabled' in all three areas and publishing messages/capturing LCRS/enabled notifications and the queues are both created and queue-to-queue is set to true. The database links have been tested and the 2 database listeners are configured correctly. However, the STRMMON shows no actual propagation happening and there are basically no messages being applied, even though both of these processes are enabled with no errors. I followed the following metalink doc very closely in terms of setting init params and also applied 8 of the most recent patches for streams. The patching has eliminated issues like excessive flow control and various ORA-errors, but the problem seems to be with queuing and/or propagation. I've referenced the Oracle Streams Concepts & Admin Guide as well as the Streams Replication Guide, ran the Metalink Health Checks and there are no errors from over 30 queries I've run. 10.2 Streams Recommendations Overview of Oracle Streams =========================== Streams can be configured in many different ways depending on the business requirements requirements. Streams can be used for such diverse tasks as data replication, data warehousing 418755.1 17-DEC-2007 The queues and propagation colums are 0 and the DDL and DML changes I'm making at source aren't being shipped to the destination. I'm attaching a snapshot of the STRRMON and the health checks from both source/destination. I have configured the parameters, but would really appreciate some specific advice on how to get the Streams process enabled and active. Although capture shows enabled with no errors, somehow the enqueue/dequeue processes aren't propagating the changes made. I originally used impdp to import the exact same objects into identical schema, created newly, in both environments, so there should be no issue with SCN mismatches. Is there some schema/table level instantiation (recursive=>all) cmd that I need to give and if so what is the syntax or is there a need for supplemental logging (i've forced logging at the database level, but I'm trying to do schema-level replication)... Please keep in mind that I've seen all of the oracle/metalink docs and parsed through quite a few of the forums strings, but still no luck. Hopefully I'm just missing one piece of the puzzle that someone can help me identify based on their experience.
STREAMS - configuration errors   (216 Views)
In the process of configuring a streams environement for bi-directional replication between two oracle databases I get an error at the ' capture phase'. While Creating capture process at database 1, i.e the package furnished hereunder: BEGIN DBMS_STREAMS_ADM.ADD_TABLE_RULES( table_name => 'gkuser1.tmp', streams_type => 'capture', streams_name => 'capture_db1', queue_name => 'str.strmuser_queue', include_dml => true, include_ddl => true); END; I am getting the errors as under. BEGIN * ERROR at line 1: ORA-01422: exact fetch returns more than requested number of rows ORA-06512: at "SYS.DBMS_STREAMS_ADM", line 75 ORA-06512: at "SYS.DBMS_STREAMS_ADM", line 21 ORA-06512: at line 2 Pl advise i. What does this error mean ii. How to rectify the same iii. Please also advise the initialisation parameters required for setting up the streams envir. regards gkrish
package compilation errors   (179 Views)
Dear Sir, Three of my packages are not getting compiled and they show errors. The errors are as follows: Warning: Package Body altered with compilation errors. Errors for PACKAGE BODY SYS.DBMS_REPCAT_RGT: LINE/COL ERROR -------- ----------------------------------------------------------------- 1146/9 PL/SQL: Statement ignored 1147/36 PLS-00705: exception 'MISSING_OFFLINE_DIRPATH' used in expression requiring return type alter TYPE BODY CTXSYS.CATINDEXMETHODS compile * ERROR at line 1: ORA-00922: missing or invalid option Errors for PACKAGE BODY SYS.DBMS_REPCAT_RGT: LINE/COL ERROR -------- ----------------------------------------------------------------- 1146/9 PL/SQL: Statement ignored 1147/36 PLS-00705: exception 'MISSING_OFFLINE_DIRPATH' used in expression requiring return type alter TYPE BODY CTXSYS.TEXTINDEXMETHODS compile * ERROR at line 1: ORA-00922: missing or invalid option Errors for PACKAGE BODY SYS.DBMS_REPCAT_RGT: LINE/COL ERROR -------- ----------------------------------------------------------------- 1146/9 PL/SQL: Statement ignored 1147/36 PLS-00705: exception 'MISSING_OFFLINE_DIRPATH' used in expression requiring return type Kindly give ure suggestions,
Routine that check for errors in Alert.log & email U only if error is found   (313 Views)
Hi Guys, How can I create a routine that check for errors in Alert.log and email me ONLY if an error is found Any suggestions
Replication errors   (233 Views)
iam facing the following error during adding a new column in replicated table: ora-12012: error on auto execute of job 6 ora-23357: the propagator does not exists ora-06512: at "SYS.DBMS_DEFER_SYS" line 1716 ora-06512: at "SYS.DBMS_DEFER_SYS" line 1804 ora-06512: at line 1 how to fix these errors. One more question, can i add a table in replicated schema but this table I don't want to put in replication.
trigger to trace user session errors   (286 Views)
I have the below trigger to trace user sesssion: create or replace trigger trace after logon on database begin if user = 'BATCH' then execute immediate 'alter session set sql_trace=true'; end if; end; / but as soon as this trigger created, the user will get errors when they log on to the DB, the errors ORA-00604
redo log file errors, database stop processing, seek help   (229 Views)
I am seeking help from this forum. I have an Oracle 9i dev DB on Unix solaris. I accidently startup DB with archivelog mode. When I import a big dmp file. first redo log files are full and cause DB stop processing. Oracle error code are: ORA-00257, ORA-16038, ORA-19502, ORA-00312 for first redo log files. I shutdown DB and try to startup DB in noarchivelog mode again. I want logswitches to start working again to write to next redo log group. However, space for DB has been out. error message is: SVR4 Error 28. DB can not be started up. Can I solve this problem by manually deleting the first rodo log files to make some space available. Then, I can startup DB in noarchivelog mode again. At this circumstance, I can finish import jobs. Then I can find time to configure the storage space for this DB and server. Or if you have better approaches, please give me some details.
Recovery Using RMAN Giving errors   (130 Views)
I am trying to recover a lost datafile using rman and get errors. Here is the script I am running and below that are errors. RMAN> run { 2> allocate channel c2 type disk; 3> restore database; 4> recover database; 5> release channel c2; 6> } RMAN-03022: compiling command: allocate RMAN-03023: executing command: allocate RMAN-08030: allocated channel: c2 RMAN-08500: channel c2: sid=11 devtype=DISK RMAN-03022: compiling command: restore RMAN-03022: compiling command: IRESTORE RMAN-03023: executing command: IRESTORE RMAN-08016: channel c2: starting datafile backupset restore RMAN-08502: set_count=3 set_stamp=428428372 RMAN-08019: channel c2: restoring datafile 1 RMAN-08509: destination for restore of datafile 1: C:\ORA805\DATABASE\SYS1ORCL.O RA RMAN-08019: channel c2: restoring datafile 2 RMAN-08509: destination for restore of datafile 2: C:\ORA805\DATABASE\USR1ORCL.O RA RMAN-08019: channel c2: restoring datafile 3 RMAN-08509: destination for restore of datafile 3: C:\ORA805\DATABASE\RBS1ORCL.O RA RMAN-08019: channel c2: restoring datafile 4 RMAN-08509: destination for restore of datafile 4: C:\ORA805\DATABASE\TMP1ORCL.O RA RMAN-08019: channel c2: restoring datafile 5 RMAN-08509: destination for restore of datafile 5: C:\ORA805\DATABASE\USR2ORCL.O RA RMAN-08019: channel c2: restoring datafile 6 RMAN-08509: destination for restore of datafile 6: C:\ORA805\DATABASE\TEMPORCL.O RA RMAN-08019: channel c2: restoring datafile 7 RMAN-08509: destination for restore of datafile 7: C:\ORA805\DATABASE\REC_DATAOR CL.ORA RMAN-03026: error recovery releasing channel resources RMAN-08031: released channel: c2 RMAN-00569: ================error message stack follows================ RMAN-03002: failure during compilation of command RMAN-03013: command type: restore RMAN-03007: retryable error occurred during execution of command: IRESTORE RMAN-07004: unhandled exception during command execution on channel c2 RMAN-10032: unhandled exception during execution of job step 1: ORA-06512: at li ne 148 RMAN-10035: exception raised in RPC: ORA-19624: operation failed, retry possible ORA-19504: failed to create file "C:\ORA805\DATABASE\REC_DATAORCL.ORA" ORA-27038: skgfrcre: file exists OSD-04010: option specified, file already exists ORA-06512: at "SYS.X$DBMS_BACKUP_RESTORE", line 925 RMAN-10031: ORA-19624 occurred during call to DBMS_BACKUP_RESTORE.RESTOREBACKUPP IECE
rman sbt errors   (203 Views)
My backups have started failing intermittently with sbt errors It will fail on allocating channels, sometimes the first, sometimes the third. Usually, but not always I can start another backup session immediately after one fails and it will run successfully. Any ideas The database in on NT 4.0 version 8.1.7 The omniback client resides on NT 4.0 version 4.1 The omniback cell server is on HP 11.0 version 4.1 Here is the error stack RMAN-03022: compiling command: allocate RMAN-03023: executing command: allocate RMAN-08030: allocated channel: dev_2 RMAN-08500: channel dev_2: sid=15 devtype=SBT_TAPE RMAN-08526: channel dev_2: MMS Version 65.4.10.176 RMAN-03022: compiling command: allocate RMAN-03023: executing command: allocate RMAN-00571: =========================================================== RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS =============== RMAN-00571: =========================================================== RMAN-03007: retryable error occurred during execution of command: allocate RMAN-07004: unhandled exception during command execution on channel dev_3 RMAN-10035: exception raised in RPC: ORA-19554: error allocating device, device type: SBT_TAPE, device name: ORA-19557: device error, device type: SBT_TAPE, device name: ORA-27000: skgfqsbi: failed to initialize storage subsystem (SBT) layer ORA-19511: Unknown SBT error code = 704755104, errno = 16 RMAN-10031: ORA-19624 occurred during call to DBMS_BACKUP_RESTORE.DEVICEALLOCATE
mysql odbc database, syntax / connection not close errors   (204 Views)
usingSystem; usingSystem.Configuration; usingSystem.Web; usingSystem.Web.Security; usingSystem.Web.UI; usingSystem.Web.UI.WebControls; usingSystem.Web.UI.WebControls.WebParts; usingSystem.Web.UI.HtmlControls; usingSystem.Diagnostics; usingSystem.IO; usingSystem.Text; usingSystem.Data.SqlClient; usingSystem.Data; usingSystem.Data.Odbc; publicpartialclassRegistration:System.Web.UI.Page { protectedvoidPage_Load(objectsender,EventArgse) { //http://cooltext.com/
Transactions and MySQL - foreign key errors   (200 Views)
Hi. I have table A and table B stored in a MySQL 5.0 database . Table B has a foreign key which points to table A. Whenever my transaction gets to inserting into Table B, it cant see the row added prevoously into Table A and throws a foreign key error. Auto_commit is currently set to '1' on my database. I'm stumped. Pleeease help.
How to debug data adapter errors in visual studio   (254 Views)
Hi. I've gota C# application that uses an ODBC connection to retrieve data from a DB2 database. When running the application I get the following error: [OdbcException: ERROR [HY000] [IBM][Client Access Express ODBC Driver (32-bit)][DB2/400 SQL]SQL0802 - Data conversion or data mapping error.] Now it just so happens that this application is designed to retreive the data through a mail merge in word. It's using the Microsoft.Office.Interop.Word assembly to create a Word.Application object, then passing the necessary ODBC connection string and sql statement to the word document's MailMerge.OpenDataSource() function. When I run the application which opens open the deed word document, and activate the mail merge feature, a certain number of records will be successfuly retrieved before I get the above mentioned error. As such, I was able to tell exactly which record contained the problem that was causing the exception. It turns out that the following sql expression SELECT * FROM CXLIB.TABLE WHERE CAST(SUBSTR(LTRIM(CXLIB.TABLE.FIELD), 2, LENGTH(CXLIB.TABLE.FIELD)) AS INTEGER) > 40 which is using an integer castto compare a dollar amount is failing when encountering a dollar amount that contains a comma. I'm still looking into resolving this problem. But it occurred to me that had I not been working witha Wordmail merge, I would have been at a lossin determining the cause of the problem. In fact, I triedduplicating this query in a separate application that usesanOdbcDataAdapterto fill a dataset and the exception is thrown immediately after the DataAdapter's fill method. Lacking experience, I would have had no clue that a certain number of records had been successfully retrieved and would have thought instead that there was a problem with my connection. Can anyone educate me on how I could have successfully debugged this issue within Visual Studio or elsewhere
ORA-01036 and ORA-00903 errors   (308 Views)
i am an absolutly newbie in programming with asp.net, so I spent much time with the following problem. I work with Visual Web Developer 2005 on a oracle 8i database. First my code: Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load Dim conString As String Dim command As OracleCommand Dim connection As OracleConnection Dim sql As String Dim amountRows As Integer Dim parameters As Integer Dim test_param As OracleParameter conString = "..." connection = New OracleConnection(conString) command = New OracleCommand command.CommandType = Data.CommandType.Text command.Connection = connection test_param = New OracleParameter(":test", OracleType.VarChar) command.Parameters.Add(test_param) sql = "SELECT * FROM PADR WHERE Zuordnung = ':test' " test_param.Value = "L" command.CommandText = sql connection.Open() command.Prepare() query.Text = command.CommandText.ToString() parameters = command.Parameters.Count parameter.Text = parameters Try amountRows = command.ExecuteNonQuery text.Text = amountRows.ToString Catch ex As Exception text.Text = ex.Message End Try End Sub Executing the code produces the following error: ORA-01036, means the variablename is unknown. If i change the select-statement to "SELECT * FROM :test" and adjust the parameter with a new value i get the ORA-00903 error. I think the parameter is not processed. What did i wrong I tried very much and searched very long for a solution in the web, but i didnt find. So i hope someone can help me.
decode causing errors   (250 Views)
ok i have a big query in a stored procedure. If i run the query on my oracle server it returns me the correct results. If I call the stored procedure from a .NET page and then output the results to the screen the data is incorrect. The stored procedure returns a data_cursor and i put the records in a datatable on the .net side. QUERY ------------------------------------------------------------------------------------ OPEN DATA_CURSOR FOR SELECT ID, NAME, POINTER, SUMMARY, DATECREATED, DATEMODIFIED, DOWNLOADCOUNT, DISPLAYINLINEFLAG, TOTALRECORDS FROM ( SELECT dataobjects.*, rownum rn FROM ( SELECT caw_dataobjects.ID, /**************************************************************/ /** If i put these decodes in with the where clause that is currently commented out, it returns the right results to .NET put all the NAME with the different record are the same, this happens with poitner and summary as well. If I put the where clause in and remove the decodes it works fine. The problem is i need both!! ***************/ DECODE(UPPER(AUserLangPref), 'F', caw_dataobjects.NAMEF, 'E', caw_dataobjects.NAMEE) NAME, DECODE(UPPER(AUserLangPref), 'F', caw_dataobjects.POINTERF, 'E', caw_dataobjects.POINTERE) POINTER, DECODE(UPPER(AUserLangPref), 'F', caw_dataobjects.SUMMARYF, 'E', caw_dataobjects.SUMMARYE) SUMMARY, caw_dataobjects.DATECREATED, caw_dataobjects.DATEMODIFIED, caw_dataobjects.DOWNLOADCOUNT, caw_dataobjects.DISPLAYINLINEFLAG, count(*) OVER () totalrecords FROM ( SELECT DISTINCT(caw_dataobjtargetcommunities.dataobject_id) FROM caw_dataobjtargetcommunities WHERE caw_dataobjtargetcommunities.id IN ( SELECT a.dataobjtargetcommunity_ID FROM caw_communityintersections a WHERE a.community_id IN (SELECT * FROM TABLE(CAST(ExtendedCommunityList as OneDNumberArray))) GROUP BY a.dataobjtargetcommunity_ID HAVING COUNT(*) = ( SELECT COUNT(*) FROM caw_communityintersections WHERE dataobjtargetcommunity_ID=a.dataobjtargetcommunity_ID ) ) AND caw_dataobjtargetcommunities.dataobject_id IN ( SELECT DISTINCT(a.dataobject_id) FROM caw_dataobjectclassifications a, caw_moduleconditions b WHERE (a.classification_id = b.classification_id OR a.classification_id IN ( SELECT caw_classifications.id FROM caw_classifications START WITH ((caw_classifications.id = b.classification_id) and (b.showchildclassifications = 1)) CONNECT BY PRIOR caw_classifications.id = caw_classifications.parent_id ) ) AND b.moduleexpression_id IN ( SELECT ID FROM caw_moduleexpressions WHERE module_id = AModuleID ) GROUP BY a.dataobject_id, b.moduleexpression_id HAVING COUNT(*) >= ( SELECT COUNT(*) FROM caw_moduleconditions WHERE moduleexpression_id=b.moduleexpression_id ) ) ) x inner join caw_dataobjects on x.dataobject_id = caw_dataobjects.id /**************************************************************/ /** Removing the where clause below and keeping the above Decodes will return the correct results in .NET ********************************************/ --WHERE caw_dataobjects.DATECREATED > AStartDate ORDER BY DECODE(ASortOption, 0, caw_dataobjects.DATEMODIFIED, NULL) DESC, DECODE(ASortOption, 1, caw_dataobjects.DATECREATED, NULL) DESC, DECODE(ASortOption, 2, caw_dataobjects.DOWNLOADCOUNT, NULL) DESC ) dataobjects where rownum = ALowerBound;
Web Service --> Oracle causing timeout & not logged in errors   (299 Views)
I have written a web service in ASP.NET using Oracles provider (ODP.NET) to connect to an Oracle 9i database. I then have a web application in ASP.NET accessing the web service. My problem is that after an hour or so, if I refresh the web page, I get the following error: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Oracle.DataAccess.Client.OracleException ORA-02396: exceeded maximum idle time, please connect again at Oracle.DataAccess.Client.OracleException.HandleErrorHelper(Int32 errCode, OracleConnection conn, IntPtr opsErrCtx, OpoSqlValCtx* pOpoSqlValCtx, Object src, String procedure) ............. Also, every morning when I go to this web page for the first time, I get an error similiar to this one, about not being logged in to Oracle. The basic problem seems to be that when I close my connection to Oracle (ex: con.Close()) that Oracle isn't letting go of the connection. Is there a fix for this A known workaround This makes my web service fairly useless.
One or more errors occurred during processing of command. ORA-00936: missing expression   (325 Views)
Could SomeOne Help Me I got this error massage: One or more errors occurred during processing of command. ORA-00936: missing expression Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.Data.OleDb.OleDbException: One or more errors occurred during processing of command. ORA-00936: missing expression Line 56: & " Order By CourseName" Line 57: Conncmd = New OleDbCommand(strSQL, dbConn) Line 58: dr = Conncmd.ExecuteReader() Line 59: ddlCourse.DataSource = dr Line 60: ddlCourse.DataBind() My Code If Not Page.IsPostBack Then Dim Conn As New ConnClss() Dim dbConn As OleDbConnection Dim strSQL As String Dim Conncmd As OleDbCommand Dim dr As OleDbDataReader dbConn = Conn.GetConn() dbConn.Open() strSQL = "Select Distinct(CourseID), CourseName" _ & " From Course Where CourseID In (Select CourseID From Section_tbl Where CollegeID=" & Session("CollegeID") & ")" _ & " Order By CourseName" Conncmd = New OleDbCommand(strSQL, dbConn) dr = Conncmd.ExecuteReader() ddlCourse.DataSource = dr ddlCourse.DataBind() dr.Close()
WebReports: REP-51018 / REP-50004 errors   (393 Views)
, When deploying my Forms/Reports 9i application over the Web with my Linux server, I get REP-51018 and REP-50004 errors when I try to call WebReports from WebForms. 1) Any anyone ran into this problem before 2) Would reinstalling Forms/Reports 10g without any SSO (Single Sign ON) feature resolve this matter I have read that I should use the SYNCHRONIZE keyword before the call to Web.Show_document + make changes to my (report server).conf file + make changes to my rwservlet.properties file. 3) Any insight into this issue