D2006 crash when trying to debug COM dll

when trying to debug a specific COM dll the IDE crash, or i get only the
CPU Debug video or it just get stuck.. other COM Dll's debugging works fine,
fellow workers doesn't have problems with debugging that DLL as well but on
my computer it keeps crashing...

any ideas

tnx, roi.

Posted On: Friday 28th of September 2012 09:54:25 PM Total Views:  747
View Complete with Replies

Related Messages:

Recommendations: Graphical debugger that supports symbols?   (308 Views)
i'm looking for a graphical debugger that supports MS symbols/symbol server 1. Delphi. Graphical, no symbols 2. WinDbg. Symbols, non-graphical 3. OllyDbg. Graphical, no symbols 4. Visual Studio. Graphical, symbols(), just can't make it work Any other suggestions
D2007 debugging too much code   (349 Views)
I debug a D2007 program and find it annoying that stepping though my code with F7 from a breakpoint leads me into the code of standard delphi units as well. I only need to see what goes on in my own code. This is probably a matter of using proper settings in Tools/Options, but I have not been able to find the correct settings. - Any suggestions Claus
Preventing debugger to halt on special exceptions   (349 Views)
, This has been a long time problem and I never found a solution, so finally decided I should ask. I want to write a function that does some calculations and returns false if some part fails, for example when I get an overflow or an invalid floating point as a result. Example: function TrySomething: Boolean; begin Result := True; try DoSomethingThatMightRaiseFloatingPointException; except Result := False; end; end; Now it is pretty common that TrySomething returns false which is ok and expected. The user will never see the exception, but when debugging I get frequent floating point exceptions which is pretty annoying. I could tell the debugger not to halt on floating point exceptions, but I do not want to generally deactivate them, since when calling other functions than TrySomething they should be raised as usual. Any idea
BDS 2006 .NET - Another debugging question   (423 Views)
Hi all, In debugging an EXE, I am setting my first breakpoint on "Application.Run(TWinForm.Create)". I am trying to find out how a particular global variable is being set. So far, I have done a "Find in files" but the only thing that comes up is one line, the place where the global variable (named "gWFile" in my case) is passed to a function. At the breakpoint, mentioned above, the Watch window displays the global variable's value so it must be being set earlier than this point. As far as I am aware, this breakpoint (Applicarion.Run) should be he start of the program so my question is: How is this global being set I have noticed that as I close the resulting window, the debugger stops and I get back to Edit mode and a *.INI file for the EXE filename being created in the same folder as the EXE file. Since the creation of the INI file occurs after the main window is closed, I looked for whether an INI file is created in the code but could not find anything in the code that references the reading or creation of an INI file. Is there something I am missing in the operation of the BDS 2006 .NET ide for global variables Is there an earlier breakpoint location than "Application.Run
Delphi 7: How do I debug with component without code ?   (352 Views)
I am working in Delphi 7 for the first time in a long time. I am doing some debugging and using a compiled component (for which I do not have code). When I step into a line with the component referenced, I get a dialog asking me where the ***.pas file is -- which I do not have. How do I avoid this and keep debugging
RAD Studio 2007: compiler error   (338 Views)
all, I stepped from BDS2006 to RAD Studio 2007. My projects are VCL.NET. In RAD Studio I very often (!) get the compiler error: [DCC Error] F2084 internal error: ILLK17428 What can I do Please help! Another thing is: The mainform has a TPageControl with several TTabSheets. After compiling the TTabSheet changes. regards Reinhard
Can Delphi 2007 .NET compile for NET 1.0 ? [for to try .NET for Symbian ]   (302 Views)
Hi Can Delphi 2007 .NET compile for NET 1.0 / 1.1 i should to try .NET for Symbian
Option "Use debug Dcu's" causes compiler error   (340 Views)
Hi all, When I check the option "Use debug DCU's" in D7 Ent I get a compiler error saying "[Fatal error] Variants.pas (1024): Program or unit 'Variants' recursively uses itself" The compiler stops at the last line in the source unit Vairants (see code far below). If I uncomment the code in "procedure VarCopyByRef" then the cursor stops way down at line 2809 instead. Why is it doing like this This means I can't debug using Dcu's (well, you already guessed that...).
My first component - giving me hell! HELP!   (384 Views)
I've started my first component recently. It is supposed to be a user account manager. I've come across a real stumbling block though. I installed it in the IDE and every few seconds was told that "Access violation at address in module JD.bpl. Read of address " So, I commented out everything and simply left the constructor and destructor - Everything worked fine. Now, I've uncommented some basic lines of the UserManager - it doesn't give me that error every few seconds but I discovered that I cannot put the component on a form and delete it. When trying to delete I get the error above. What am I doing wrong - I must be missing something but I can't see it. Its driving me NUTS Here is my stripped down component - Everything else is commented out so it isn't included here: unit JdUserManager; interface uses Windows, Messages, SysUtils, Classes, SyncObjs; type TJdUsers = class(TCollection) Private FCaseSensitiveUserName: Boolean; FCaseSensitivePassword: Boolean; Protected Public end; type TJdUserManager = class(TComponent) private { Private declarations } FIniFileName: String; //FOptions: TSetOptions; //FReadMode: TAccessMode; //FStoreMode: TAccessMode; FUsers: TJdUsers; //FUserGroups: TJdUserGroups; protected { Protected declarations } function GetCaseSensitiveUserName: Boolean; function GetCaseSensitivePassword: Boolean; procedure SetCaseSensitiveUserName(Value: Boolean); Procedure SetCaseSensitivePassword(Value: Boolean); procedure SetUsers(Accounts: TJdUsers); public { Public declarations } Constructor Create(Owner: TComponent); override; Procedure DeleteUser(UserName: String); Destructor Destroy; override; published { Published declarations } Property CaseSensitiveUserName: Boolean read GetCaseSensitiveUserName write SetCaseSensitiveUserName; Property CaseSensitivePassword: Boolean read GetCaseSensitivePassword write SetCaseSensitivePassword; property IniFileName: String read FIniFileName write FIniFileName; property Users: TJdUsers read FUsers write SetUsers; end; procedure Register; implementation procedure Register; begin RegisterComponents('JD', [TJdUserManager]); end; //------------------------------------------------------------------------------ //-*** TJdUserManager ***------------------------------------------------------- //------------------------------------------------------------------------------ Constructor TJdUserManager.Create(Owner: TComponent); begin Inherited Create(Owner); end; procedure TJdUserManager.SetUsers(Accounts: TJdUsers); begin If Assigned(Accounts) then begin //FUsers := Accounts; //commented out to try the next line.. inherited Assign(Accounts); end; end; procedure TJdUserManager.DeleteUser(UserName: String); begin //FUsers.Delete(UserName); end; function TJdUserManager.GetCaseSensitiveUserName: Boolean; begin Result := FUsers.FCaseSensitiveUserName; end; function TJdUserManager.GetCaseSensitivePassword: Boolean; begin Result := FUsers.FCaseSensitivePassword; end; procedure TJdUserManager.SetCaseSensitiveUserName(Value: Boolean); begin FUsers.FCaseSensitiveUserName := Value; end; procedure TJdUserManager.SetCaseSensitivePassword(Value: Boolean); begin FUsers.FCaseSensitivePassword := Value; end; Destructor TJdUserManager.Destroy; begin Inherited Destroy; end; //----------** End TJdUserManager **-------------------------------------------- end.
QC63192 Properties duplicating when changing focus on component   (303 Views)
I thought this was odd. Not sure if anyone else can duplicate. When selecting a component, putting focus on a property, then selecting a different component of a different type, will duplicate properties. See steps on how I did this with a bare bones project. My Delphi is under VMWare on XP Pro SP3. 1- Create New Project. 2- Add a TCheckbox 3 - Add a TEdit Box 4. Select the TCheckbox and look at the properties. Put focus in the TabOrder. 5. Select the TEdit and then look at the properties. You may or may not see 2 tab orders. If not, click in the Tab Order to put focus there. 6. Click on the TCheckbox again and look at the properties. You should see 2 Tab Order properties. Lance Rasmussen
D6 - IDE slow with code completion activated   (331 Views)
. Beside D2007 I still have a D6 installation which locks up very often when code completion is activated. It happens too often to ignore it and the IDE seems to be frozen for serveral 10-seconds without repainting its windows. Is there any solution beside deactivating this feature Like deleting some temporary files or some kind of cleanup process Rgds, Michael
Reading a different computer's registry file   (319 Views)
I have a user.dat registry file from a dead Win98 machine. What is the best way for me to open the file and extract out bits of data that I need I'm assuming the registry api's only work with the machine you are on and with the LIVE registry files. -- Best regards, Harold , "Remy Lebeau (TeamB)" wrote in message > Then you only have a portion of the Registry. You need system.dat as well. Yes I have that one too. > From a programming standpoint (since you did post this to a programming > newsgroup), you would have to open and parse the file manually. Or use a Yeah I wanted to write a program to read the keys out I wanted. the registry components I've seen seem to work only on the machine's registry where I am running the program. Can't get it to open another file, like one of the .dat files.
Posting rights in borland.public.delphi.vcl.components.using   (366 Views)
Windows Mail could not post your message. Subject '"Richedit line insertion error"', Account: '', Server: '', Protocol: NNTP, Server Response: '480 you do not have posting access to {borland.public.delphi.vcl.components.using}', Port: 119, Secure(SSL): No, Server Error: 480, Error Number: 0x800CCCA9 What is the problem here
Write a comment to INI file   (332 Views)
I create a new ini file and I want add some comments before first section. something like : ## Immettere indirizzo TCP/IP se necessario nella forma ## I tried : writestring ('','','## Immettere indirizzo TCP/IP se necessario nella forma'); but I get an access violation ... Which instruction should I use
my project work on my computer but not on another   (364 Views)
Hi I have program with a SQL connection on my computer works fine and whan I connect remotely on the another computer it works but when I start program from the remote computer it doesnt work error: Error reading ADODatatbase1.Connected[DBNETLIB] ConnectionOpen(Connect()) ] SQL Server doesnt exist or access denied it is strange becouse when I connect remotely to the same database from my computer it works fine what can be the problem I use DATALINK for the connection string Squirrel --- posted by geoForum on
Query Service Config crashing app   (226 Views)
I have an application where I'm trying to get the Start type for a service. I think I'm doing something wrong but I'm not seeing it. Everything seems to work but when I have the call to this routine in my code I will get an access violation at some point either when trying to close the dialog or when trying to set the state of a component after this call. If I remove the call to this routine everything behaves properly. I was wondering if someone could catch what I'm doing wrong. Here is the routine I'm calling to get the config status of my service. function TdtmShared.GetServiceConfig: dWord; var SvcMgr: Integer; SvcHdl: Integer; ServiceName: String; ServiceConfig: TQueryServiceConfig; dwBytesNeeded: Dword; begin result := SERVICE_DEMAND_START; SvcMgr := OpenSCManager(nil, nil, SC_MANAGER_ALL_ACCESS); try if (SvcMgr = 0) then begin RaiseLastOSError; Exit; end; ServiceName := 'MyService'; SvcHdl := OpenService(SvcMgr, PAnsiChar(ServiceName), SERVICE_ALL_ACCESS); try if (SvcHdl = 0) then begin RaiseLastOSError; Exit; end; if (QueryServiceConfig(SvcHdl, @ServiceConfig, 240, dwBytesNeeded) = False) then begin if (QueryServiceConfig(SvcHdl, @ServiceConfig, dwBytesNeeded, dwBytesNeeded) = False) then begin RaiseLastOSError; Exit; end; end; result := ServiceConfig.dwStartType; finally CloseServiceHandle(SvcHdl); end; finally CloseServiceHandle(SvcMgr); end; end; When I have this routine in place I get the correct start type returned. I can figure is maybe I'm not freeing something properly.
my project work on my computer but not on another   (388 Views)
Hi I have program with a SQL connection on my computer works fine and whan I connect remotely on the ather computer it works but when I start program from the remote computer it doesnt work error: Error reading ADODatatbase1.Connected[DBNETLIB] ConnectionOpen(Connect()) ] SQL Server doesnt exist or access denied it is strange becouse I connect remotely to the same database and from my computer it works fine what can be the problem I use DATALINK for the connection string
How to debug COM DLL:s in D7????   (299 Views)
I am tearing my hair off over this... I have this COM dll that I am working on. It is supposed to be called from another program using the COM registration and then it will show its form and the user can perform some data handling and then close the form and the dll is returning to the caller program with the data. Fine, this works without problem. We have many such projects and they usually are quite simple to develop. But this one drives me mad because it seems absolutely impossible to get the D7 debugger take hold of the dll and allow me to step through the code to find the bugs. Is there somewhere a stepwise guide on how one can debug dll code that I can use The thing that drives me nuts is that if I open another similar COM dll project in D7 that uses the same host application as the caller then D7 lets me debug that! The blue dots appear and the breakpoints are honored. I even compared the dof files for the two projects to see if there are any obvious differences but I could not find any.... Where should I start looking for a solution to this I really need to get the bugs out and it is almost impossible without being able to step through the code. Notice that the dll I compile is actually the one being called too, every visible change I make is there. It's just that the debugger does not get a grip on it. :-( -- Bo Berglund
Abandoned projects/components   (359 Views)
, I am proud Delphi developer for ten years and I am a little upset that many component developers abandoned their projects. Let's say it is very powerful components for supporting Window shell system. This project do not has competitors and it is only one components such type available for Delphi. Unfortunately ShellPlus team abandoned project, they no longer answer to forum(forum full of s*x adds), do not answer to support, do not release new version. There are many such projects which had great success and suddenly disappeared. I understand why it happened so, there is no marted for Delphi components anymore, it was big some time ago but not know. Maybe CodeGear team could buy these great abandoned projects, take development of them and include in Delphi as default components What do you think