SEARCH YOUR SOLUTION HERE  

bzip2.dll for download (or can someone compile it?)

Hi all,

I'm out hunting for bzip2.dll for use with Delphi classes (DI or Jcl
Decompressors), but can't find a recent version ready compiled for Win32

Although google gives many hits on "bzip2.dll" but I don't trust
clicking any of those cheap .dll mouse traps which is now littering the
entire Internet.

Latest source (1.0.5 as of mars 2008) is available from here,
http://www.bzip.org/downloads.html

Perhaps can anyone compile it for me (or give a hint about a secure
link for download).

Anyone

Posted On: Monday 24th of September 2012 10:00:52 PM Total Views:  375
View Complete with Replies




Related Messages:

how can i include version info with delphi exe while building with MSBUILD   (236 Views)
I have able to set the version while building delphi executable by using the D2007 by enabling include version information in project. But i am using MSBUILD to build my .dpr in command prompt. I want to include the version info with MSBUILD
D2007 compiler warning msg: Inline function 'AnsiSameStr' has not been expanded because unit 'Windows' is not specified in USES list   (172 Views)
I am getting the following compiler warning msg: [DCC Warning] ConfigINIFile.pas(661): H2443 Inline function 'AnsiSameStr' has not been expanded because unit 'Windows' is not specified in USES list what does it mean
cannot focus a disbled or invisible...   (200 Views)
.. I have this piece of code: if (fProxControl nil) and fProxControl.CanFocus and fProxControl.Enabled and fProxControl.Visible then fProxControl.SetFocus;
Initialization section with circular references is not correctlyhandled by the compiler!   (234 Views)
all! I just encountered a possible bug in the delphi compiler and circular references. I often use a scheme like this: unit test; interface procedure AddClassToList(cl : TClass); implementation var fList : TClassList; procedure AddClassToList(cl : TClass); begin if not Assigned(fList) then fList := TClassList.Create; fList.Add(cl); end; initialization fList := nil; finalization fList.Free; end. So far so good. The problem is that if one includes a unit within this unit and call the AddClassToList procedure in it's initialization procedure the list is created as expected BUT afterwards the initialization section of the test unit is executed, so the fList variable gets nil assigned! I know I should have been a bit more carefully but I think the compiler should at least throw a warning for circular reference or that a function is called before the initialization of this unit is executed. What do you think kind regards Mike
D2007: AV when compile & run using BPLs   (168 Views)
I am getting an AV when I compile and run with BPLs. (with BPLs, my app compiles so much faster--it's 27 megs without BPLs, 10 with). The AV is: --------------------------- Debugger Fault Notification --------------------------- Project C:\trak\trak.exe faulted with message: 'access violation at 0x7c937a50: write of address 0x00040f74'. Process Stopped. Use Step or Run to continue. --------------------------- OK --------------------------- Am I correct to lok for modules loaded at the $7c937a50 adress If so, the closes items are: I see the list of the DLLs & BPLS that are loaded--the only thing close to the address is ntdll.dll and Shell32.dll: Module Load: ntdll.dll. No Debug Info. Base Address: $7C900000. Process trak.exe (5848) Module Load: SHELL32.dll. No Debug Info. Base Address: $7C9C0000. Process trak.exe (5848) So it would seem that the AV occurs in the ntdll.dll, correct Which doesn't really tell me much. My only guess for moving this forward would be to remove BPLs from the list until the AV is gone, then examine that BPL. Or is there a better method
[Delphi 2007] How can i set that delphi start form # from 1(after starting a new VCL project)?   (217 Views)
Ahmadi wrote: > After starting new VCL Form Project, my form and unit #(postfix number) is 5 > , sometime is 4! It uses the lowest number that's higher than any of the forms or units that are already in your project folder. > Its wonderful that if my first form # is 5 and i create new form its number > is 7 !!! > [Delphi 2007] How can i set that delphi start form # from 1(after starting a > new VCL project) Delete the other form or unit files from your default project folder. Better yet, give your forms and units meaningful names. The numbers don't tell you or anyone else what your forms or units are for. -- Rob
How can I share code or create a static library in Delphi ?   (149 Views)
I have two related projects in my project group (Delphi 10, BDS 2006) that share a number of files, in a tree like this: ProjectGroup - Common - Utils.pas - ZLib.pas - Components.pas - GraphicApp.exe - MainApp.pas - GUI.pas - ConsoleApp.exe - MainConsole.pas - CLI.pas Now GraphicApp and ConsoleApp projects both use files in project Common. I would like Common to be some sort of a library project, library that GraphicApp and ConsoleApp would depend on. Does Delphi have native libraries Or can I set it somehow to output even a C++ like .lib file, and then use it in my other projects But I would still like to have types and forms in my library, and I am afraid this is hard to do with a .lib file I tried to create project Common as a package project, but then it would create a run-time file Common.bpl which works kind of like a ..dll, only in a Borlad - specific format. Meaning it has to stay near the executable, which my clients might not like, or be included in the system's PATH variable. I do not want any dll or dynamic libraries, I only have a number of source files that I want to use in both projects and what I need is a static library or some object files of some kind. Can I create a package like a static library, that would be linked in at compile time Does Delphi have a native static library format Or can I have some kind of project that just compiles the .pas files to .dcu files and then puts them somewhere, where I can use them in the other projects Every kind of project I saw wants to output some sort of executable, different than the .dcu files. Kind regards, Timothy Madden
D7--can run project, D7 locks up   (229 Views)
I can only run my application a few times inside of D7 then Delphi and the app lock up after loading the application and I have to end-task Delphi, which makes development really slow. The app shows up in the Task Managers 'Processes' list. The compiled line indicators show up on the left side of the tray. I put a break point on the DPR's 'begin' and it doesn't get there. Any hints on what I might look for D7, Windows XP.
Can someone explain this?   (105 Views)
--
AV in Delphi 2007 compiled application   (171 Views)
We have a enterprise suite developed back with Delphi 4. Last year we have converted our code to Delphi 2005 and everything it was ok. In last month we decided to move all code to Delphi 2007. Everything went well except one application which start crashing when exit from it. Everthing works except when Exit from application. AppName: dlydispatchconsole.exe AppVer: 8.0.0.1 ModName: borlndmm.dll ModVer: 4.76.0.177 Offset: 000049ad Exception EAccessViolation in module borlndm.dll at 000049AD. Access violation at address 00D249AD in module 'borlndmm.dll'. Write of address 004BC608. Same code compiled with Delphi 2005 does not raise the exception. Any ideas TIA, Costica Moldovanu
Unit SOUT was compiled with a different version of ZIN.Tcat... re-building doesn't fix it   (165 Views)
Everyone, I changed a type I made called Tcat in unit ZIN and re-built the project. Unfortunatley the error poped up even after a re-build so I assumed the DCUs might be messed up. So, I renamed the DCUs and then re-built and got a 'File Not Found SOUT.dcu'. I put the path to the PAS files in my library path and browse path and I still get the same errors. I re-named the DCUs back to their original names and I'm getting the original error again about being compiled with a different version. Any ideas
Is BDS 2006 Enterprise full featured C# compiler?   (152 Views)
, I have BDS2006 Enterprise and a potential customer who want's a webapplication in C#. So I wander if there are traps when I use BDS2006 for this. I did make Win32 and ASPNet applications with it and for once tried to open a C# project and the latter failed on some files. Is it safe to start a web development in C# with a SQL-Server database
(rant) Ending 8 months of nuisance - ditching Vista at last   (93 Views)
Having put up with Vista ultimate for 8 months now, I've decided to format the hard disk of my notebook and install XP professional again. The reason for my decision is not Vista's dreaded UAC, which I find a good thing actually, but rather the fact that I am much less productive using Vista than using XP. I spend much too much time doing stuff like searching for things that are no longer where they used to be under XP. That's just a never-ending nuisance. Under XP, I can instruct someone to click his way to the IP settings of his network adapter with my eyes closed. Under Vista, I'm lucky if I can get it done myself . Stuff like network connections, WLAN connections, the "common"' and "user" desktop folder etcetera are just no longer where I expect them to be and are buried much too deep. It just makes no sense to find my "personal" start menu under "C:\Users\Arthur\AppData\Roaming\Microsoft\Windows\Start Menu" and the "common" start menu under "C:\ProgramData\Microsoft\Windows\Start Menu", the guy who thought that out must have been smoking something illegal. Anyway, I'm really looking foreward to be with my old friend XP again. -- Arthur Hoornweg (In order to reply per e-mail, please just remove the ".net" from my e-mail address. Leave the rest of the address intact including the "antispam" part. I had to take this measure to counteract unsollicited mail.)
Component writing... help needed please!   (172 Views)
Hi all Right, I've created the basic part of my component - TJdUserManager. In this component I have 2 TCollections - TJdUsers and TJdUserGroups. Within both of those collections I have Collection Items - TJdUser and TJdUserGroup respectively. What I want to do is have a property in TJdUser to select a TJdUserGroup. In the object inspector I am looking to create a drop down list of the available TJdUserGroups so that I can select one group membership which will be associated with that TJdUser.Group property. I'm assuming the .Group property will need to be a pointer to a TCollectionItem Basically, its similar to Indys TIdTCPClient - where you can select a IOHandler/Intercept as soon as it is dropped on the form. Obviously my TCollectionItems are not dropped on the form though! Also, when I create a new TJdUserGroup in the object inspector I'm assuming the name of the item must be stored somewhere in a list to be made available to the TJdUser Can you point me in the right direction with tips/source samples
Passing parameters within ""   (123 Views)
Hi I've got a problem... I'm passing a url as a parameter (its a rdp:// protocol for use with a custom RDP client I'm making) I've got the RDP side of things working but I'm having trouble with the rdp:// link. Basically I'm passing it URL encoded in the following format: rdp:///v: /u:"Firstname Lastname" /p: URL encoded it is: %2Fv%3A%3Cserver%3Aport%3E+%2Fu%3A%22Firstname+Lastname%22+%2Fp%3A%3Cpassword%3E I can pass the normal parameters (/v: /u:"Firstname Lastname" /p:) in the command line and there are no problems. However when I process them myself from the decrypted URL encryption, I am parsing each parameter by the space between them. This causes me a problem with "Firstname Lastname" as it doesn't recognise the double quotes! It simply takes the Firstname and Lastname as 2 seperate parameters. This is the code I've used for parsing the URL encrypted information: If Pos('rdp://', ParamStr(I)) 0 then begin NMURL := TNMURL.Create(nil); //Create NMURL component from FastNet library for decoding url encrypted strings Temp := ParamStr(I); Temp := Utils.ParseRemove(':', Temp, 1); Delete(Temp, 1, 2); NMURL.InputString := Temp; Temp := NMURL.Decode; repeat Params.Add(Utils.Parse(' ', Temp, 1)); //This is where First and Last names are not passed as a whole string Utils.ParseRemove(' ', Temp, 1); until Temp = ''; I can see why it obviously doesn't pass the username as a whole string because it is parsing via the space. What I'm having trouble with is working out how to check for double quotes and use the string within them as one parameter and add it to the StringList. Can anyone show me a quick and easy way of checking for double quotes and parsing by them without me spending hours head scratching
Source Code limit   (98 Views)
my current Delphi 2006 Project had: 200 000 compiled source code lines The compiler works hard but fine (in general) Sometimes i belive the compiler forgett any lines to compile but I'm not sure, so i push the compile button twice. Is there a limit, or anybode knows a limit of compiled lines. How many compiled lines is your biggest project.
CriticalSection problem on TThread class !   (126 Views)
Ahmadi wrote: > Im using one CriticalSection structure in my Thread. > If i define my CriticalSection variable out of my TThread object(i > mean global), i have no error, and allthings is fine. but if i define > CriticalSection variable as a member of the TThread object(public > member), then i have access violation sometimes that im trying to use > enterCriticalSection or leaveCriticalSection ! Very likely that you free your CS object inopportunely or make an attempt to enter into not yet initialized CS. Please show your actual code. > what is different between this two definitions in this situation > (global and public member) No difference. > I think it seem that there is a > bug/limitation/violation problem/myWrong in TThread class and > RTLCriticalSections. It's possible but probability is low. :-) -- Alex
How can i load TImage picture from a TMemoryStream that contain TJpeg data?   (163 Views)
"Ahmadi" wrote in message news:486e356f@newsgroups.borland.com... > How can i load TImage picture from a TMemoryStream that contain TJpeg > data You have to load the TMemoryStream into a TJPEGImage, and then you can Assign() that to the TImage.Picture property. > jp:=TJPEGImage.Create; Since you already have the TJPEGImage, you can get rid of the TMemoryStream completely, ie: var jp: TJPEGImage; begin ... jp := TJPEGImage.Create; try ... Image1.Picture.Assign(jp); finally jp.free; end; ... end; Gambit
whats wrong with this?   (168 Views)
My compiler/debugger/.exe suddenly has a problem with one line: if a[Result] s then These are the current variables when the debugger hits the above line and crashes: a: array of string;// 'v', 'u', 'p' s: string; // '/v' Result: Integer //3 It has worked faultlessly previously but I've just got home from the cinema, run the program and found it crashes with this message: "Access violation at address 00404913 in module 'Project1.exe'. Read of address FFFFFFFF." I've then recompiled and found it still happens. Traced into the code and for no apparent reason it is also crashing. This has been tried on both my desktop PC and the VM where I run the IDE. Am I missing something here , I must of been way too tired last night... I was thinking about re-writing the loo0p, using a For to do etc etc Fixed it with two characters: -1 - EG Before: function CaseOfString(s: string; a: array of string): Integer; begin Result := 0; while (Result < Length(a)) and (a[Result] s) do Inc(Result); if a[Result] s then Result := -1; end; After: function CaseOfString(s: string; a: array of string): Integer; begin Result := 0; while (Result < Length(a) -1) and (a[Result] s) do //Changed this line Inc(Result); if a[Result] s then Result := -1; end; Instant fix... "Sven Pran" wrote in message news:486f2fd8$1@newsgroups.borland.com... > "Jamie Dale" wrote in message > news:486eb017$1@newsgroups.borland.com... >> Nevermind... I don't know why it worked before when it shouldn't but I >> just realised that the code uses 0 as an index in an array with 3 >> strings. When it hits 3 I've not got the fourth string to compare >> against. > > I believe that if the size of the array was ever set to 4 (or greater) > then your code should not crash even if a[3] did not have any value > assigned Could that be the difference between "before" and "now" > > regards Sven
local variables initialization? ERangeError   (109 Views)
I have stumbled across a most (to me) surprising error: In one of my functions I have a local array of typed variables that each must have an ordinal value in the range 0 .. 3 My first statement in this function is a for loop assigning each array element an initial valid value, but the statement S[I] := some valid value results in ERangeError: Range Check Error caused by the fact that at entry to the local function this array contains random values which in most cases of course are outside the valid range. I had expected local function variables to be initialized to low-values (binary zeroes) when the function is entered, but even if not so I am most surprised that an assignment statement which need not first read the variable can result in an ERangeError caused by the value in that variable before a new value is assigned being out of range Comments or clarifications anybody regards Sven