SEARCH YOUR SOLUTION HERE  

deploying ASP.net web application

Hi Guys,

I am trying to deploy my web application onto a TV through a device call NetX card. I published my web application into IIS but i want to deploy these web pages. I know of NetBeans, it has this function call Deploy. However VS doesn't have the deploy function.

Is there anyway to deploy my aspx web pages

I am using VS08, C#.

Posted On: Tuesday 30th of October 2012 01:02:11 AM Total Views:  179
View Complete with Replies




Related Messages:

Re: Read Excel 2007 File into ASP.NET application   (70 Views)
I can't get this code to work. I keep getting the same error that it can't find my worksheet. The worksheet's name is UploadProspectsTemplate. I try it with the $, I try it without the $, I tried subscripting it (0), I am running out of things to try. I also don't know what the magic word Employees is supposed to be. I am doing this elsewhere in my application successfully and I have XLData as the second parameter to oleda.Fill, but I don't know for certain what that is supposed to be either. Please tell me if you see what's wrong as I am going nuts. Code: Dim connString As String connString = "Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" & Server.MapPath("UploadProspectsTemplate_RES.xlsx") & ";Extended Properties=Excel 12.0;HDR=YES" ' Create the connection object Dim oledbConn As OleDbConnection = New OleDbConnection(connString) Try ' Open connection oledbConn.Open() ' Create OleDbCommand object and select data from worksheet Sheet1 Dim cmd As OleDbCommand = New OleDbCommand("SELECT * FROM [UploadProspectsTemplate]", oledbConn) ' Create new OleDbDataAdapter Dim oleda As OleDbDataAdapter = New OleDbDataAdapter() oleda.SelectCommand = cmd ' Create a DataSet which will hold the data extracted from the worksheet. Dim ds As DataSet = New DataSet() ' Fill the DataSet from the data extracted from the worksheet. ' oleda.Fill(ds, "Employees") oleda.Fill(ds) Me.gvSampleFile.DataSource = ds Me.gvSampleFile.DataBind() There are 10 kinds of people. Those who understand Excel and ASP.NET and those who don't and should just go home and give up.
Re: Problems deploying   (161 Views)
I've trawled the net looking for an answer to this but havn't found anything that works. I have a .net site that has been written and precompiled by an outside contractor that is to be deployed to several laptops and run on localhost so that the app can be used offline. They have sent me a seup program and it installs ok and when i install it on my pc (that i use for development) it all works as it should. The problem comes when i install it on the laptops. when i run the site i just get a message saying that the file has not been pre-compiled and cannot be requested. I've checked the files and they are the same as on my pc (the aspx files are just the stub and not the actual files) and i've been through IIS with a fine tooth comb. Both machines are running Vista and the configuration of IIS appears to be identical and i know the files are...... Does anyone have any clue as to what the problem could be This is driving me nuts and my boss is on my back to get it fixed, but i dont know where to look for answers next. Please Help!!!!!
Strange problems deploying   (129 Views)
[2005] I have added a web deployment project to my website/solution. The problem I am having is that when I right click on the deployment solution then choose "Add Project output" the only item appearing in the listbox is "Content Files". Where are all the others I seem to remember doing this a couple of years ago and there where further entries supporting installation of the .net framework e.t.c
[2005]deploying a web site in asp.net   (166 Views)
, I am posting in this asp.net segment for first time. I have a basic question. What are the basic criteria for a server to host .net web project. I am using web2005 as the ide. I tried to install framework 2.0 on my server where windows 2003 is installed. But the files are not accessible through live ip. It is giving error like Code: Server Error in '/' Application. -------------------------------------------------------------------------------- Compilation Error Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. Compiler Error Message: BC30002: Type 'VS2005' is not defined. Source Error: Line 7: Protected Sub cmdLogin_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles cmdLogin.Click Line 8: Try Line 9: Dim vs As VS2005 Line 10: vs = New VS2005 Line 11: I have this dll in my localhost and it is working fine. Even ide identifies it by itself. But when i tried it to put in server it is not identifying the .dll. Any way out and any suggestion are welcomed.
error when deploying on ASP.NET application on windows server 2003   (169 Views)
Is it possible that your installation package is missing the FillComboBox library Is this something that you installed manually on your Development machine, and hasn't yet been installed, or included in the installation package How did you create the installation package Gary
error when deploying on ASP.NET application on windows server 2003   (206 Views)
Is it possible that your installation package is missing the FillComboBox library Is this something that you installed manually on your Development machine, and hasn't yet been installed, or included in the installation package How did you create the installation package Gary
***RESOLVED*** sqlconnection technique for deploying   (125 Views)
Hi all,I created a web app(forms) on my test machine and I deployed it on my web server. Now everything was working fine on the test machine but I'm having problems on the web server. This is my first time deploying a web app so I noticed that my code needed some changes. For exemple, I have images in the forms and on my test machine I had them just about anywere on the hard drive. But I didn't think about what would happen on the web server. Anyways I figured out that I had to place them in the directory of the web app in inetpub/wwwroot and had to write the path relative to my application directory. Just an exemple of begginers mistakes.One problem I can't seem to figure out is the sqlconnection I have. I created an swlconnection in the form but the connection string is for the test machine db. SO on my web server this doesn't work since the machine name isn't the same. I don't know how to change it so it works on both machines at the same time. I thought using localhost would work but I'm having trouble with that. Here's my string:workstation id=MYMACHINE;packet size=4096;integrated security=SSPI;data source=MYMACHINE;persist security info=False;initial catalog=Demo2My db have the same name on both machines (Demo2) but not the workstation id and data source. What is the best way to write this string so that when deploying I don't have to change everything
help on deploying aspx pages online   (177 Views)
hello please clarify my doubt regarding deployment of aspx page on webserver. I had designed a small .aspx page which displays the databse information from a MS Access DB(.mdb) file. I had written code in vb.net using ASP.NET Technology. I am success in displaying database table values in a .aspx page using web browser using IIS a local host(server) But how to deploy the page in world wide web. I am attaching my files here.What path must we give to access the database file.below i marked in red color.Code: [vb] Sub Page_Load(ByVal Sender As Object, ByVal e As EventArgs) Dim objConn As New OleDbConnection ("Provider=Microsoft.Jet.OLEDB.4.0;" & "Data source=http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">;http://www.w3.org/1999/xhtml"; > Untitled Page First name: Last name: Address: City: State: Zip: Phone: [/vb]please help me.
deploying web application fails with runtime errors about extensions   (132 Views)
I have built my web application. It works the way it is supposed to on the ASP.net development server in VS2008. I published the application to the directory on the web server, without error. However, when I try to run the application through a web browser on the target web server, I get the a runtime error shown in the browser and the following entry in the event log:Code:Event code: 3006 Event message: A parser error has occurred. Event time: 7/6/2008 8:51:53 AM Event time (UTC): 7/6/2008 1:51:53 PM Event ID: 72dd092d68fe4577a3f308c2545687e6 Event sequence: 4 Event occurrence: 1 Event detail code: 0 Application information: Application domain: /LM/W3SVC/78972690/Root/ed/clsi-3-128598259123032177 Trust level: Full Application Virtual Path: /ed/clsi Application Path: C:\Inetpub\labr\ed\clsi\ Machine name: SERV1 Process information: Process ID: 2848 Process name: w3wp.exe Account name: NT AUTHORITY\NETWORK SERVICE Exception information: Exception type: HttpParseException Exception message: Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. Request information: Request URL: http://www.labr.net/ed/clsi/clsi1.aspx Request path: /ed/clsi/clsi1.aspx User host address: 10.232.1.1 User: Is authenticated: False Authentication Type: Thread account name: NT AUTHORITY\NETWORK SERVICE Thread information: Thread ID: 1 Thread account name: NT AUTHORITY\NETWORK SERVICE Is impersonating: False Stack trace: at System.Web.UI.TemplateParser.ProcessException(Exception ex) at System.Web.UI.TemplateParser.ParseStringInternal(String text, Encoding fileEncoding) at System.Web.UI.TemplateParser.ParseString(String text, VirtualPath virtualPath, Encoding fileEncoding) at System.Web.UI.TemplateParser.ParseFile(String physicalPath, VirtualPath virtualPath) at System.Web.UI.TemplateParser.ParseInternal() at System.Web.UI.TemplateParser.Parse() at System.Web.Compilation.BaseTemplateBuildProvider.get_CodeCompilerType() at System.Web.Compilation.BuildProvider.GetCompilerTypeFromBuildProvider(BuildProvider buildProvider) at System.Web.Compilation.BuildProvidersCompiler.ProcessBuildProviders() at System.Web.Compilation.BuildProvidersCompiler.PerformBuild() at System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) at System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)I mean, I have been slowly deleting these references from the web.config file, but that doesn't seem to make sense to me. If they were needed on the ASP.Net development server, then they will be needed in the web server (IIS 6.0). What did I miss copying or doing so this will wor
Re: Want to make sure I'm deploying correctly   (165 Views)
We have a web application that I've just enhanced (and gotten rid of the MsgBox in it , too!) It runs on our production web server. I have the solution loaded in VS2005 on my PC. It's been deployed before, but this is the first time I am deploying it and I want to make sure I know what I'm doing. So I will choose Publish from the Build menu, and I think I want to say Remote Site - is that what will plop all my new stuff over the old And is the value that I supply for Remote Site the URL, or would I use the IP...or are any of these questions way off base and I clearly don't know what I'm doing and should stop NOW
Re: Doubt in deploying ASP.NET?   (125 Views)
I have developed a asp.net application with SQL SERVER backend. I need help in deploying in the application. Step: 1. I copied all the files like aspx files and html files into the Internet web site web folder. Step 2 : Now how can i copy sql server database in to internet world. Where I have to put database files. And how will they work Help is required. Yours, Senthil
Re: [2005] deploying web service to remote IIS   (187 Views)
, I am trying to deploy a web service to a remote computer. The remote computer is on the local network. On my development computer I have a webservice that just displays hello world. On the solution I click copy web site. I connect to the remote computer and send the web.config, and service.asmx over to the remote IIS. I then go back to my developer machine and try and view the service.asmx over the internet. I get this following message. Server Error in '/webserviceTest' Application. Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. I thought this would be a straight forward thing, but i have spent many hours trying to solve. Does anyone have any ideas,
[resolved] deploying a project on the web   (167 Views)
i have a general question regarding deploying a project on the web... when i copy the project files onto the web, and place them in the root, the application works fine... but if i place the files into a subfolder, for example, www.somesite.com/subfolder/login.aspx instead of www.somesite.com/login.aspx, i get an error... but i don't want to have 50 files clogging the root and want to organize things a bit, so how do i get this work thanks all here's the error message (error is on line 31): Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. Source Error: Line 29: by Microsoft that offers a single logon and core profile services for member sites. Line 30: --> Line 31: Line 32: Line 33:
deploying crystal report   (209 Views)
hai, im developing asp.net with crystal report bundled version. Application running successfully in my system. But the same is not in another system (crystal report not installed). wat R the requirements to deploy the application. Thank U v.r.mahedran
Newbie need help deploying asp 2.0 app to web server   (214 Views)
I am working on a project in asp 2.0 in vs 2005, it works fine on my machine but when i tried to deploy it i get access denied, the application has a fileupload controls when the user selects a file it will upload the file to the server which is hosted by a hosting company i configure the asp settings using their control panel to allow write, read, basically every setting their is to get this thing to run, the web application will also read, upload files, create subdirectories, & create .xmls what do i have to do to get this to work
moving / deploying a website   (209 Views)
I am trying to move a project from my machine onto a IIS webserver and have it run when people view the pages.I was following http://support.microsoft.com/id=326495 "How to move your Visual Studio .NET Web project to another computer" but its just not working.there were a few small glitches like I didnt understand the bit about the .sln file (The mention it but never where to save it or how to build a new one)I can try running the project through Express Edition and when it runs it will still be using Localhost. If I navigate directly to the webserver with a browser it will not load the file. So how does one change the basic files into something that IIS will serve u
deploying asp net   (206 Views)
How do I set my web app on the web I don't know whta are the steps needed to do that first I have my app in visual studio ...what files do I need to keep I'm using reports in crystal so...What libraries do I need to use ... I have the host with ftp... How Do I put my app in there... Plz I would really appreciatte ur help ..And how do I connect my app with the database in sql..What Do I put in the we config ,...server IP only Jimmy
The page cannot be found error after deploying into live server   (193 Views)
Hi all, I am new to ASP related projects. I compiled a demo ASP.Net (with C#) and uploated into our Internet (live) server. but when I try to open the site, it shows 'The page cannot be found - The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.', along with 'HTTP Error 404 - File or directory not found.Internet Information Services (IIS)' erros. I tried several times by changing ASP.Net version from 1.1 to 2.0, then by creating VDIR, but no use. Where I am missing Please guide me.
having problems deploying a web site   (191 Views)
I am trying to put my project to our server (windows server 2003) though the copy project is VS 2005 and whenever I tried to run it through my internet explorer this error message comes out...Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Unrecognized attribute 'xmlns'.Source Error: Line 8: \Windows\Microsoft.Net\Framework\v2.x\Config Line 9: -->Line 10: http://schemas.microsoft.com/.NetConfiguration/v2.0">;Line 11: Line 12:
Problems after deploying a Silverlight Application using WCF service   (310 Views)
again Im hoping to be on the right topic. So here it is: I am publishing a SilverlightApplication that uses a WCF service to read from a database. The application uses Bing Maps to visualize some polygons. The thing is, that after I publish it ONLY on some machines I get the following Error: at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary() at ServiceConnection.MyServiceReference.selectImotsByEkatte_visualCompletedEventArgs.get_Result() at Tracing.Views.DrawContent.client123_selectImotsByEkatte_visualCompleted(Object sender, selectImotsByEkatte_visualCompletedEventArgs e) at ServiceConnection.MyServiceReference.Service1Client.onselectImotsByEkatte_visualCompleted(Object state) Caused by: [Async_ExceptionOccurred] Arguments: Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft....ceptionOccurred at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary() at ServiceConnection.MyServiceReference.selectImotsByEkatte_visualCompletedEventArgs.get_Result() at Tracing.Views.DrawContent.client123_selectImotsByEkatte_visualCompleted(Object sender, selectImotsByEkatte_visualCompletedEventArgs e) at ServiceConnection.MyServiceReference.Service1Client.onselectImotsByEkatte_visualCompleted(Object state) Caused by: [Async_ExceptionOccurred] Arguments: Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft....ceptionOccurred at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary() at ServiceConnection.MyServiceReference.selectImotsByEkatte_visualCompletedEventArgs.get_Result() at Tracing.Views.DrawContent.client123_selectImotsByEkatte_visualCompleted(Object sender, selectImotsByEkatte_visualCompletedEventArgs e) at ServiceConnection.MyServiceReference.Service1Client.onselectImotsByEkatte_visualCompleted(Object state) Caused by: [Async_ExceptionOccurred] Arguments: Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft....ceptionOccurred at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary() at ServiceConnection.MyServiceReference.selectImotsByEkatte_visualCompletedEventArgs.get_Result() at Tracing.Views.DrawContent.client123_selectImotsByEkatte_visualCompleted(Object sender, selectImotsByEkatte_visualCompletedEventArgs e) at ServiceConnection.MyServiceReference.Service1Client.onselectImotsByEkatte_visualCompleted(Object state) The machines I refer to have different OS. Meaning that on some machines with XP it works fine, on others doesnt, on some machines with winodws 7 it works fine but on others doesnt and etc. , so I believe it is not an OS based problem. The interesting thing is that I am confident that some of the methods that the application calls from the service work fine, beacause in the beggining of the application you are asked to log in as a user, and the method that validates the user reads from the database and executes on the service, therefore it calls the service successfuly. So some machines have no problem with the login proccess and then they give this error when pressing a button that calls the method mentioned in the eror. Others give the error when trying to log in. (Of course the error that they give in the login fase is with different error message, but the difference is only in the method mentioned in the message. It is again a Async_ExceptionOccurred Debugging resource strings are unavailable... ) So, in some cases I am confident that there have been previous calls to the service that were successful, yet at a certain point it gives that error. I have absolutely no idea how to deal with that and what might be the problem. In more details how I publish the project. (I am confident that all my connection strings are correct) I build the Service in Release mode ( tried in debug too) then I publish it in Filemode. I run it while it is in release mode and in the client I configure the service refence to be on localhost:(servicePort), I do that because the service and the client are on the same machine, then I build the project again tried in both Debug and Release, and publish it in filemode. I then copy the folders on the servermachine. Through IIS7 I create a new site for the service and in the default document I add on the top Service1.svc . I configure the site to open on the same port that the service was run through the studio that I mentioned above, so the service connection configuration in the client to be at the correct port. After that I create a new site for the Client and in the default document I move my default.aspx file on top. The application pools that I use on both projects are ASP.Net v4 So this is everything I can think of, tell me if there is more information that is needed, I am really hoping that I find a way to fix the problem, because it is a deal breaker. I thank you in advance and apologise if I have made some newbie mistakes or didnt explain everything well enough, Im new in programming.